14

I want to copy files from OS X (El Capitan) to my Nexus phone (which uses Android 6) and vice versa. And I just mean copying locally, i.e. over USB cable, I want to avoid overcomplicating things with upload and download through intermediary servers.

In the past I used Android File Transfer for this. But that was with a previous OS X version, and my old phone with Android 5. I tried again, but it doesn't work anymore, it keeps saying:

Can't access device storage.

If your device's screen is locked, disconnect its USB cable, unlock your screen, and then reconnect the USB cable.

The screen is most definitely not locked, and dis+reconnecting the USB cable (either end) doesn't help.

  • If you want to do this without a USB cable, take a look at the app Airmore: File Transfer. – james.garriss Nov 30 '16 at 14:33
16
  1. Pull down notification menu.
  2. Tap "USB for charging / Touch for more options"
  3. Tap "Transfer files (MTP)"
  • Awesome! Apparently this is new in Android 6, I assume this was also where Alexey was referring to. Works great! – RocketNuts Oct 15 '15 at 17:18
  • 1
    I had to do this AND install the Android file transfer utility referenced by TheBro21 below. I expected the device to show up in Finder like a USB drive, but no dice. Had to use the stand-along transfer program. – Trenton Apr 22 '16 at 17:06
  • In Settings -> Sound & notifications -> Notifications? In Android 6 we just have "When device is locked", and "App notifications". This answer needs updating. – bitsand Jul 30 '17 at 18:54
  • 1. Swipe down from the top of the screen with one finger 2. Place finger on notifications screen and move finger towards the top of the screen until you see "USB charging this device / Tap for more options" 3. Tap "USB charging this device / Tap for more options" 4. Tap "Transfer files" – Cedric Jul 31 '17 at 20:23
  • And what about on the Mac side? These steps work on my PC where I can then access the Android folders via File Explorer. But the same Android on my Mac with the same USB cable, the Mac seems to do nothing. I can't find any sign of the device in the Finder. The phone is charging through the cable. – hippietrail Aug 23 '17 at 1:44
3

In Android 6 there is new connection mode - charging from usb. In this mode you can't transfer any data. I faced it on my Nexus 5 with El Capitan.

Solution was easy - change connection mode to data transfer. I used this mode before, but with Android 6 phone set default connection mode to "charging".

  • 2
    Sounds good, exactly how or where do you change this connection mode? – RocketNuts Oct 15 '15 at 17:12
  • Did the trick with changing from USB charging to File transfer work more than once for you guys? For me it worked once but next time I tried to use the same workaoround I could no longer access the file transfer via Android file transfer. – Tanja Nov 30 '15 at 20:46
  • If I had enough points I'd -1 for not giving details. Lazy. – geotheory Jun 27 '17 at 22:51
1

As far as I know, you need drivers in order to do that. You can download android drivers for instance here. Linux Ubuntu seemingly allows this already from my experience but it didn't work all the time and threw cannot mount errors. Rooted phones also make it easier to transfer files.

People could have problems with the update to Android 6 or El Capitan. You can in that case try re-installing, or enabling developer options (Tap build number in about this device in settings 7 times to unlock developer options, then enable USB Debugging).

  • I already have Android File Transfer (from the exact same site you mentioned) and it used to work fine in the past, but now it keeps saying my phone is locked or not connected. Even though it is connected, and not locked. I'm not sure whether this has to with the EL Capitan and or Android 6 upgrade? By the way I've never had to mess around with drivers (again, it worked fine in the past, no drivers were involved at that time either). – RocketNuts Oct 15 '15 at 16:46
  • @RocketNuts Try re-installing the drivers. Might be the android 6 change too. Try also developer options (Press Build number 7 times in settings) – TheBro21 Oct 15 '15 at 16:55
  • Sorry, are we talking about the same thing? I re-downloaded Android File Transfer (there was nothing to install, really, just dragged the app to my Applications folder) and ran it again, still same problem. Not sure what you mean by 'Press Build number 7 in settings', how / where is that? The Android File Transfer app doesn't seem to have any settings....? – RocketNuts Oct 15 '15 at 17:01
  • 1
    Yep, enabled USB debugging. I noticed that when I switch USB debugging off and on, the Android File Transfer window pops up, same as if I disconnect and reinsert the USB cable. So it does seem do something, or send some kind of signal. But still, it comes up with "can't access this device" immediately (similar to when I reinsert the cable). – RocketNuts Oct 15 '15 at 17:15
  • 1
    Ah, found it after all! See @Cedric's solution. – RocketNuts Oct 15 '15 at 17:19
0

So I was having this same problem with my LG G4 + OSX El Cap interface and could not find anything to get a USB connection. After repeated poor data transfers (errors) with the LG Bridge, I started searching again and found a site that suggested FIRST to download AppCleaner to scrub the residual system files out. Then delete all android interface apps (Bridge, Kies, etc). I even deleted Android File Transfer to preclude the possibility for corruption. I ran my file scrubber and deleted any residual system files, then reinstalled AFT. IT WORKED!!! I hope this solves your problem if none of these other ideas worked.

You must log in to answer this question.

protected by Community Mar 14 '16 at 9:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .