I have both an iPad and an iPhone, and I sync them both with the same computer. I read a lot of ebooks, and I keep them in iBooks, so that I can switch between all my devices. (I also have a number of audiobooks, which I only use from my phone or laptop, never from the iPad).

I have all my devices set to automatically sync all books. But for a while now, when I've synced the iPad, it's reset itself to sync "Selected books" instead of "All books", so that I've had to go back to iTunes and re-select "All books" and do a second sync in order to get all of my books transferred.

This only happens with the iPad, not with the iPhone. I've had this iPad for a while; I don't recall having had the issue the whole time, but I also don't recall exactly when it started or if I did something to cause it.

I have tried doing a complete reset and reinstall of the iPad, but the problem came back as soon as I'd done my first sync.

Is there any way I can make iTunes stop resetting my book sync preferences?

  • I have the same problem. This has been going on for months. It seems to happen whenever I add a new book via drag-and-drop to iBooks.
    – Peter C
    Commented Oct 18, 2015 at 16:09

1 Answer 1


I got the idea to compare the settings for the iPhone and the iPad. The only difference was that I'm syncing all my audiobooks to the phone, but not to the iPad.

So, I turned on the setting "Sync audiobooks" and "All audiobooks". And now the system no longer resets to syncing only selected ebooks.

  • Can you elaborate on where you found that setting? I can't seem to find it in iTunes or on my iPad's settings, but am having this exact issue. Thanks! Commented Jan 5, 2016 at 20:32
  • 1
    It's in iTunes, when your device is connected you have a list of settings on the left side of the window. Below "Books" there's "Audiobooks", that's where the setting is.
    – Jenny D
    Commented Jan 5, 2016 at 20:49
  • I still have no idea why this setting mattered, it seems nonsensical to me... but it did solve the problem.
    – Jenny D
    Commented Jan 6, 2016 at 11:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .