10

The solution to this problem in previous versions of OS X was a checkbox in the trackpad preferences that said "ignore accidental trackpad input." That option is no longer there in Yosemite.

Is it still possible to enable it, and if so how?

7
+25

If you have a multi-touch trackpad Mac, the option no longer appears in System Preferences because it as enabled automatically. See https://support.apple.com/en-us/HT201822.

Update 2016-04-03-1007
You may want to give BetterTouchTool a try. It enables fine grained control of trackpad behavior. Three items that may interest you in particular:

  1. Disable trackpad gestures after hitting a keyboard key to prevent accidental gestures while typing
  2. Thumb recognition (filters out thumb and palm . . .)
  3. Reenable gestures only after touching the center area of the trackpad
  • 2
    Interesting...I guess the problem is it thinks my input is not accidental then. Maybe it's the new hardware because my hands haven't changed and I did not have this problem after enabling that option on previous macbooks. Thanks for the answer regardless. – user148073 Mar 31 '16 at 19:17
  • @tubes I am having the same issue, I am typing then my palm taps the trackpad, the new trackpad with force touch, and then I am typing on a different line. I was really hoping to fix it – Jaketr00 Apr 1 '16 at 3:52
  • @tubes Does this command work for you? defaults write -g com.apple.trackpad.setWantsRestingTouches -bool TRUE – Itay Grudev Apr 11 '17 at 10:19
8

I changed "Click" to "Firm" in the menu.

System Peferences > Trackpad > Point & Click

It seems to have helped.

  • I had that setting but still it sometimes jumped on me. Electrical tape method works like a charm! :) – lacostenycoder Apr 24 '17 at 17:58
  • Definitley helps a bit versus the default setup. I still have issues sometimes, but it does seem to reduce the frequency of the issue. – Benzo Jul 1 '17 at 13:36
5

I was having similar issues after purchasing a new MBP. What seemed to fix it for me was to go into System Peferences > Trackpad > Point & Click and disable the following items:

Look up & Data (Tap with three fingers)
Force Click and haptic feedback

Since I don't need any of those features I just disabled all of them. I code and don't use a lot of fancy trackpad features. Try playing around with those options to see what works best for you. If you need those options some of the time, you could probably make a script to quickly toggle them on and off.

UPDATE: Non-technical HACK:

While some of these tricks seemed to have helped, I found a very easy way to eliminate accidental thumb clicks while typing. Place a 1/2 inch width strip of electrical tape across the top of the trackpad. It may not look pretty but it gets the job done with no further hacks required!

To insure the area of electrical tape is not trackable, use 2 layers of tape with a thin strip of aluminum foil between the layers. You probably could use clear or scotch tape for the top layer for a thinner profile. Just be careful the foil doesn't make direct contact with the trackpad itself as this will disable the trackpad. I recommend cutting the foil to be slightly smaller than the electrical tape.

Easy Electrical Tape Hack

  • 1
    Touches passed through two layers of electrical tape when I tried it. A middle layer of aluminum foil stops that, but that's getting pretty thick. Why is it bad for the foil to touch the trackpad? – arlomedia Oct 22 '17 at 4:20
  • As mentioned, you can try 2nd layer with clear tape for thinner profile. If foil touches pad, the pad just won't work. – lacostenycoder Oct 22 '17 at 18:16
  • 1
    I've been using one layer of aluminum foil covered by one layer of electrical tape. The aluminum touching the trackpad hasn't caused any problems for me. This works pretty well because it's almost exactly the same thickness as the drop from the case surface to the trackpad surface. I put it all the way around (all four sides) because I found it difficult not to touch the bottom of the trackpad with the palm of my mousing hand or the side of the trackpad with the hand that remained on the keyboard. – arlomedia Aug 13 '18 at 4:32
3

I created a project to address exactly this problem. Allow you to adjust size of ignored area on Trackpad, The ignored area won't respond to any touches. It’s as if it’s not part of trackpad.

enter image description here enter image description here

enter image description here

2

I created TouchGuard to address exactly this problem. TouchGuard disables the touchpad while typing on macOS. It is distributed as a pre-compiled, binary executable and a plist file and, when installed, runs as a system-wide daemon.

You can download and install the TouchGuard binary and the plist file as follows:

  1. Download the repository from GitHub:

    enter image description here

  2. Extract ZIP file to Desktop.

  3. Run this command in Terminal to make the TouchGuard executable:

    cd Desktop
    chmod +x TouchGuard
    
  4. Copy TouchGuard to /usr/bin/ folder.

  5. Copy org.amanagr.TouchGuard.driver.Daemon.plist to /Library/LaunchDaemons.
  6. Reboot.
  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Aug 29 '18 at 18:00
  • @lacostenycoder What makes you think this answer is more dangerous than any other answer recommending to download a binary without public source code? – nohillside Mar 27 at 16:40
  • @lacostenycoder There are a lot of answers on this site which recommend binaries. Not everybody favors open source. – nohillside Mar 27 at 18:06
  • YOU RUN THIS AT YOUR OWN RISK. I opened an issue on github asking to show the source code and the user just closed the issue and removed issues from public view. How can you trust it? – lacostenycoder Mar 27 at 19:07
1

Update

Karabiner Multitouch extension no longer works on newer versions of MacOS so I recommend turning of tap-to-click when typing.

Use this Apple Script to toggle "typing mode" if you want be sure your trackpad wont mess you up during frenetic typing sessions

open Applications > Utilities > Script Editor and paste the code from this script:

tell application "System Preferences"
    reveal anchor "trackpadTab" of pane "com.apple.preference.trackpad"
end tell
tell application "System Events" to tell process "System Preferences"
    click checkbox 3 of tab group 1 of window 1
end tell
quit application "System Preferences"

Then select File > Export and save in Applications but also make sure to select File Format > Application before saving.

If you want to make it very easy to run the toggle on and off, you may want to add a custom keyboard shortcut which would just run the toggle application

Outdated

I'm currently on El Capitan but this should work with any supported version of https://pqrs.org/osx/karabiner/

You can actually play with the settings and disable thumb clicks on the top part of the trackpad. enter image description here so this more or less does what my tape hack does sans the tape!

UPDATE: I was not able to get this do completely fix accidental tap while typing. So here is my final advice:

For $6.50 you might wanna purchase Better Touch Tool For Mac which improves accidental thumb taps but not 100% perfect.

Try these advanced settings: enter image description here

enter image description here

  • How do you get that window w/ touchpad adjustment in Karabiner? I downloaded it but cannot find it anywhere, is it a separate extension or something ? – AlexVPerl Dec 21 '18 at 8:38
  • @AlexVPerl from karabiner preferences select Misc & Uninstall > Launch "multi-touch extension" > Area – lacostenycoder Dec 21 '18 at 16:51
  • 1
    thanks for reply, but latest version I dl'ed does not have that button, what version are you using? – AlexVPerl Dec 21 '18 at 19:19
  • @AlexVPerl probably I'm using a very outdated one. I'm still on El Cap. – lacostenycoder Dec 21 '18 at 21:21

You must log in to answer this question.