1

After updating to OS X El Capitan 10.11 and updating to Xcode 7.0.1 I ran into some issues with the simulator.

At first the simulator would launch but I couldn't register/log in to the app because the ATS Key was needed. That was added, but now there is a different issue.

Whenever I try to launch the simulator, it appears in my dock, but it's inactive. It doesn't ever actually open and if I click on it's options, it shows that he simulator is not responding.

It had worked initially when I opened Xcode using sudo in terminal, but trying that again, I still am running into this issue. I've been looking everywhere online to find if anyone has had the same problem, and I've yet to find a solution.

  • They have Xcode 7.2 now - does upgrading it fix the problem? – Cullub Dec 28 '15 at 18:16
1

I had the same problem on my 13in non-Retina MacBook Pro. I fixed it by going to my project, building and running the project, and when the Simulator.app opened, I pressed the "Stop" button.

This worked for me, but it must be a bug in Xcode 7.0.1 because just a few days ago my simulator was running fine.

0

The first thing to do is to isolate the issue to a user setting or a system issue. Actually, powering off the Mac would be the first thing to do and then re-test things in the current user/new user.

  • make a new user and fire up Xcode in that user
  • test the simulator there

Ask a follow on question with details of this step - how to fix a broken Xcode installation is different than fixing a broken user environment / settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .