2

All setting are correct. Tried following some other site's suggestions but nothing has resolved the problem, so now what should I do? Keys worked before the install.

MacBook Pro (Retina, early 2105) 2.7 GHz 8 GB

  • Hi and welcome to AskDifferent! You may want to add some more information in there as to what you tried already, or else people trying to answer your question may just duplicate non-working advice. – Mikey T.K. Oct 14 '15 at 17:00
  • Question, what happens if you hold down the Fn key and then try the sound keys? – Mikey T.K. Oct 14 '15 at 17:00
  • Thanks, that's exactly what I recently found that works. Why Apple would add the fn key when it hadn't been necessary to use before is beyond my comprehension, except that it allows those three keys to be multi-functional. I deselected the box in the keyboard preferences, and it's back to normal - where it was before El Capitan. – painter33 Oct 15 '15 at 19:38
1

What happened here is that your FN key settings got reverted - there's an option that the F-keys either transmit their assigned key (so F10 means F10), or the additional function (so F10 means mute).

Normally, this is set to function mode, so F10 means mute. You can change this in your Keyboard settings in system preferences.

Keyboard preferences pane

If the "Use as standard function keys" option is turned on, you will need to hit Fn to access the mute key. If it's turned off, you will not need to hit Fn, but if you want to send an actual F10, then you need to hold Fn.

0

AUDIO KEYS WERE NOT ADJUSTING VOLUME ON MY IMAC AFTER UPGRADE TO EL CAPITAN All I did was go into System Preferences > keyboard and then uncheck (turn off) "use all F1, F2 etc. keys as standard function keys" and my apple wireless keyboard worked fine. I was able to adjust volumes audio with the keys and increase or decrease brightness on my computer. The F keys are finally working!

I have a iMac (27-inch, Mid 2010) with SSD drive, apple wireless keyboard and El Capitan 10.11.4

NOTE: I was on phone with apple support and they told me first to unplug machine, wait then replug and restart (didn't work), they then told me I would have to bring in the keyboard or mac because it is no longer on warranty and it could be a hardware issue. I disagreed. So they then had me restart with the SHIFT key, (didn't work), then they had me reset the P ramp (didn't work) they then told me to reinstall my operating system. (didn't work) So I decided to look online and try the best source. This was the first one I came to. I didn't have to follow the above directions completely, for me all I did was uncheck the first check box as mentioned above and all the keys worked!!!! Wow, and apple doesnt know this yet? Hope others find this helpful.

0

For me the solution was to reset the SMC.

0

First, Apple Tech Support is useless for this issue. After managing to insert a latte into my mid-2009 Apple extended keyboard I had to replace it. I never had an issue with the original keyboard & El Capitan, but the new one (Apple) produced non-functioning "Function" keys. After rebooting, safe-booting, resetting PRAM, etc. with no improvement I "deselected" the "Function Keys" box within "Preferences". I suspect that somewhere along the line Apple has made an internal change to the keyboard since my earlier one worked fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .