-1

I have asked this question last year. In the link below.

How to disable spotlight for Alfred

But, since the settings now changed in El Captain the answer is not valid now. Please re-answer. I don't want to stop indexing. I just to disable spotlight and assign cmd+space to Alfred.

1

The answer is almost the same as the previous answer you linked.

Disable ⌘Space for Spotlight:

  • Go to System Preferences > Spotlight.
  • In the lower left, click the button Keyboard Shortcuts... (this is the part that changed in El Capitan).
  • Now in the keyboard shortcuts menu, deselect Show Spotlight Search.

enter image description here

Note that this does not disable Spotlight. Spotlight is just not accessible via ⌘Space anymore.

Enable ⌘Space for Alfred:

  • In Alfred's Preferences choose the General tab.
  • Set ⌘Space under Alfred Hotkey .

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .