I am not able to delete user account on El capitan . The Minus (remove option ) is inactive here . I tried doing this by logging in to admin account . Please help!!!!

  • I assume that you 'unlocked' the settings in the preference panel... if so, and if you are trying to delete the only account on the machine in question, try: - add a new account, with admin privileges. - now try remove the account you want to remove. See if that works. BTW, I think you will need at least 1 account with admin powers at all times. Oct 14, 2015 at 11:52

2 Answers 2



It's possible that the user you're attempting to remove is the last FireVault capable account. You can see this illustrated by launching Directory Utility (/System/Library/CoreServices/Applications/Directory Utility.app) from the command line and attempting to remove the user:

enter image description here

From the command line, you should get something along these lines:

2017-11-06 16:08:03.777 Directory Utility[866:19875] Couldn't delete record "demouser" of type "dsRecTypeStandard:Users": Error Domain=com.apple.OpenDirectory Code=4001 "Attempting to delete the last FileVault capable user" UserInfo={NSLocalizedDescription=Attempting to delete the last FileVault capable user, NSLocalizedFailureReason=Operation was denied because the current credentials do not have the appropriate privileges.}

No matter how you launch Directory Utility or which permissions you use, you'll be unable to delete the user.


You'll need to enable FireVault if it isn't already and add the user you want to the list of users capable of unlocking the disk:

enter image description here

You can also use the command line: sudo fdesetup add -usertoadd username

After this is done, you'll be able to delete the user. You can also turn off FireVault if you feel like it.


We had a similar need to delete a local account after binding the computer to Active Directory. We accomplished this by running these commands while logged in with a network account that was granted admin.

sudo dscl . delete /Users/<username>
sudo rm -rf /Users/<username>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .