5

Summary

Since upgrading to El Capitan from Yosemite, Time Machine works manually, but automated backups and disk icons are no longer working as they should.

Detailed Problem Description

I have a brand-new system that came with Yosemite, and Time Machine was working fine. After a recent upgrade to El Capitan, I have the following issues:

  1. The Time Machine disk (an external USB 3.0 device) no longer shows up on the desktop as a Time Machine device. It shows as a standard removable disk.

    Time Machine Disk Icon on Desktop

  2. Even though Time Machine sees the device and schedules periodic backups, these backups never run. The only backups that run are the first one scheduled when the Time Machine disk is mounted, or when "Back Up Now" is selected. In this example, the manual backup I ran at 4:00pm completed, but the incremental scheduled for 4:59pm never ran.

    Time Machine settings with scheduled incremental backup.

Troubleshooting Steps

On my own, and with Apple technical support, I did all of the following in an attempt to debug:

  • Sensible things I tried on my own:

    1. Perform First Aid on the Time Machine GUID table.
    2. Perform First Aid on the Mac OS Extended (Journaled, Encrypted) filesystem on the disk.
    3. Unmount and remount the Time Machine disk.
    4. Deselect and reselect the Time Machine disk.
    5. Disable Time Machine, reboot, and reselect the Time Machine Disk.
  • Things I did at the request of tech support:

    1. PRAM reset.
    2. SMC reset.
    3. Boot in Safe Mode.
    4. Configure Time Machine as a different Administrator account.
    5. Boot to recovery partition and non-destructively reinstall OS X.

Other than performing a full erase and reinstall, I'm at a loss as to how to troubleshoot this issue further. This seems to be a bug in El Capitan, but of course there's always the possibility that some kernel extension or third-party extension like FUSE, VirtualBox, or VMWare Fusion is wrecking havoc, but I require those extensions for work.

Apple currently denies that there are any outstanding Time Machine bugs in El Capitan, but that may be due to its newness or the fact that not enough people have reported related issues yet. On the other hand, if it's really just my problem, what else can I do to debug this or work around this (e.g. a cronjob of some kind, perhaps?) short of hosing my entire system and starting from scratch?

1

I'm having a very similar problem after upgrading to El Capitan, except that I can not repair the disk, my attempt always gives me a repair failed error. I don't have an answer, but I think I can verify that the issue probably isn't related to any third-party extensions as I'm operating without. So at least I may be able to help rule out those as a source of the problem.

| improve this answer | |
1

Apple's engineers will need you to run tmdiagnose to get at the root cause. In the mean time, you could gather those logs and also try to push at the status:

tmutil latestbackup
tmutil listbackups
tmutil startbackup --rotation --auto
sleep 15; tmutil status

My guess is you have a spotlight issue or an issue mounting the drive that's failing as opposed to launchd falling down. You could make a cron entry, but I'd use a tool like Lingon to make a custom launchd job to call the startbackup command from above to at least have some periodic coverage while you gather enough information to figure out why your jobs are not starting.

Also, I would try adding a second backup destination to see if that one works more reliably - multiple backup destinations should fire sequentially - every n hours, your one drive should get a snapshot.

| improve this answer | |
1

I do not think it is just "your problem." I have a late 2013 MacBook Pro and have been unable to complete a Time Machine backup with my WD My Passport since I upgraded to El Capitan. I tried all the potential fixes you did. I also reindexed my hard drive and erased my backup drive and started fresh.

The problem persists. Namely that when I initiate a Time Machine backup the process stalls permanently about two thirds to completion each attempt.

| improve this answer | |
  • MacBook Pro (late 2013) here too. Literally 2 seconds after upgrading to El Capitan I started seeing "USB Devices Disabled" messages with no external devices plugged in. My Time Machine (external USB) drive is not longer recognized. – Laconic Droid Oct 20 '15 at 0:24
0

TL; DR

This problem of backups not starting can be worked around with crontab. This won't fix the desktop icon, but will help ensure that you have backups at regularly-scheduled intervals as defined in your custom crontab. Below, I provide an example of how to run hourly backups using sudo, cron, and a modified sudoers file

Work-Around Using Crontab

The following will kick off Time Machine hourly, after checking to make sure it isn't already running a backup as some media or backup sets may take more than an hour to complete.

# ~/.crontab
0 */1 * * * tmutil status | grep -qF "Running = 0" && sudo tmutil startbackup -a

Note that this work-around uses the user's crontab, which always needs to be brought to the system's attention after editing with:

/usr/bin/crontab ~/.crontab

Run Time Machine without Passwords

Since cron can't prompt for the sudo password, the following is also recommended:

sudo -v
sudo mkdir -p /private/etc/sudoers.d
sudo touch /private/etc/sudoers.d/$(whoami)
echo "$(whoami) ALL=(ALL) NOPASSWD: /usr/bin/tmutil" |
    sudo tee -a /private/etc/sudoers.d/$(whoami)

This will ensure that the tmutil command can be run without prompting for the user's password for sudo access when launching Time Machine from the command line.

Safety Note

It's always a good idea to have a root terminal open before editing sudoers, and to verify the custom sudoers file with:

sudo visudo -f /private/etc/sudoers.d/$(whoami)

after creation to prevent typos from locking you out of sudo access.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .