6

I'm having problems using and SMB share in my local network as a time machine destination.

I followed the tutorials widely available on the internet but in the end when I open the Time Machine app I get the error message:

Can't connect to a current Time Machine backup disk

I followed these steps:

  1. Created the sparse bundle
  2. Copied the sparse bundle to the smb share
  3. Double clicked in the sparse bundle to mount it
  4. Enabled ownership on the mounted sparse bundle
  5. Used tmutil to set the Time Machine destination as the mounted sparse bundle
  6. Opened Time Machine app.

I find this strange because I can perfectly access the sparse bundle via Finder or the terminal, and have write access:

enter image description here enter image description here

I can't really find anything in the logs in the Console app to determine what is in fact the connection trouble. Can someone please guide me to the answer?

I'm using OSX 10.11 El Capitan.

Thanks

  • Same message here with an Apple Time Capsule. – Jive Jivemo Oct 19 '15 at 19:55
9

This is going to be a throughly unsatisfying answer, but it comes down to the fact that random network drives were not meant to be used as time machine backup targets.

I'd wager one of the things you did in your guide was to run a terminal command along the lines of:

defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1

Unsupported being the watchword here.

I've run into this exact problem myself, but only when backing up to network shares.

Usually what it takes to break Time Machine out of its funk is to completely disable it (toggling the switch to off in the preferences pane), unmount your network share, remount it, and then re-enable time machine. The system is smart enough to see that you already have backups in the bundle file and you won't lose any data.

Still - you're playing with your safety net. If the contents of your machine are super important, please pick up a time capsule so you don't wind up with a nasty surprise some day.

I've no idea what triggers this behavior - it appears to be completely random.

  • Thanks man. Actually it's a very satisfying answer! After removing the destination, disabling time machine, unmounting and redoing everything it worked. Actually as this is not a really important backup I'm gonna keep it like this. That saves me the trouble of investing on a time capsule. Thanks a lot! – Joao Neto Oct 13 '15 at 21:02
4

In case you haven't found a solution yet, in the guide I was following it never mentioned to run the tmutil utility to set the backup drive via command shell, so just run the following command on a Terminal and you will have the disk selected on Time Machine Preferences:

sudo tmutil -a setdestination "/Volumes/Time Machine Backups/"

Remember to change the name of the volume, in my case as I used makeImage.sh it defaults to "Time Machine Backups"

  • 3
    You might want to add the -a option to tmutil so you don't delete all existing backup destinations. See the man page. – mts Jan 21 '17 at 3:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .