4

Is there a command in Single User Mode to recover/reinstall the start-up wheel (with root its user access).

I removed wheel as a group from any file/folder it had permissions for or access to. I didn't just change the permission, I actually clicked the (-).

enter image description here

I thought it was a hipster nickname for an actual user from the previous owner. Stupid, I know.

The problem is that without the start-up wheel, literally every reboot, restart, recover attempt gets hung up at the screen with the Apple and the spinning wheel. The only mode or screens I can access are Single User or Verbose (which can't reboot) because they are the only two that don't run through the traditional start-up path (spinning wheel).

I've tried every key +power button combo listed anywhere. No safe mode, no recovery, no boot from another drive...nothing.

System specs:

MacBook Pro, Mac OS X 10.6.8

  • @klanomath Unfortunately, I cannot remember which folders & files I took it out of. I only remembered doing it after 3 days of searching sites for my possible issue, and seeing someone refer to that ithing as the wheel. Lightbulb moment. I'm sorry. I wish I could be more specific as to whether they were system files, volumes, hard drive folders, user apps, all of the above....I just don't know. Thank you for responding. I wish I could be more help to those trying to help me! – Honeybee0919 Oct 13 '15 at 16:27
  • There are at least 10k (probably >300k) files/folders with permissions for wheel. So it's impossible to do this for every file/folder. Did you also apply the changes to enclosed folders by hitting the gear button? – klanomath Oct 13 '15 at 16:45
  • Do you have access to a CD/DVD with an OSX installer (ideally for 10.6.x)? – nohillside Oct 13 '15 at 16:55
  • Can you put the CD in and reboot with C pressed? This should start your MBP from the CD. – nohillside Oct 13 '15 at 17:38
  • No. I'm going to try making a USB drive, because the cd didn't work and I didn't partition the external hard drive correctly. I'm making the USB drive now. – Honeybee0919 Oct 13 '15 at 19:18
2

This not-really-an-answer answer probably doesn't solve your problem, though the result is so astounding/interesting not to dump it in the comment section:

I set up a virtual machine with Snow Leopard Server (10.6.8). After deleting (not just disabling rwx!) all wheel group permissions of /bin, /sbin, /private, /System and all subsequent files and folders as well as those of all relevant folders in /Library with either an admin or the root account and afterwards totally removing the group wheel with the workgroup manager, the system still boots properly. Some apps don't work properly (e.g. Terminal in the admin account; it still works in the root account).

Consequently I can't reproduce your problem.

You may try the following in Single User Mode:

At the prompt enter:

/sbin/fsck -fy
/sbin/mount -uw /
launchctl load /System/Library/LaunchDaemons/com.apple.notifyd.plist
launchctl load /System/Library/LaunchDaemons/com.apple.diskmanagementd.plist
launchctl load /System/Library/LaunchDaemons/com.apple.securityd.plist
launchctl load /System/Library/LaunchDaemons/com.apple.configd.plist
launchctl load /System/Library/LaunchDaemons/com.apple.diskarbitrationd.plist
diskutil repairPermissions /

If the loading of com.apple.configd.plist doesn't find an end you may just enter launchctl load /System/Library/LaunchDaemons/com.apple.diskarbitrationd.plist or after entering ctrlC continue with launchctl load /System/Library/LaunchDaemons/com.apple.diskarbitrationd.plist

If you don't get a new prompt :/ root# after waiting some time, you may just enter the next command. You may also modify the sequence of the five load commands. I needed three attempts to get that working.

You should now see a wall of notifications. It should take about 20-30 minutes to repair everything.

  • -I entered the final command and it told me it couldn't run because it's unable to use the DiskManagement framework, but more importantly, it says DiskArbitration framework unavailable due to being booted in single user. You have it spelled "diskarbitrition" in the above. The command is mispelled, so you may want to edit that up there. I'm going to start all over and change the sequence of the commands, and try the correct spelling of arbitration. – Honeybee0919 Oct 14 '15 at 0:23
  • @Honeybee0919 Yeah, my mistake... sorry for that – klanomath Oct 14 '15 at 4:12
  • @Honeybee0919 My answer contains the working order. The first try was notifyd->securityd->diskmanagmentd->configd->diskarbitrationd which didn't work. The second try was n->diskm->s->c->diska which didn't work neither (I got the "systemShutdowm false" endless loop). The third try was successful though. Some pages also suggest to load com.apple.kextd.plist. I have to go to work now. I will repeat everything @ 10 am your time when i'm back. – klanomath Oct 14 '15 at 5:17
2

Don't worry, your data isn't lost!

That just happened to me as I stupidly deleted the wheel group permission to my hard drive and would get a black screen just after opening my session. Here is how I fixed it:

  • cmd + R on system startup
  • Reinstall Mac OS X

When finished, you will get your hard drive permissions back and will be able to log in with your personal user again, just like all of this didn't happen.

I'm on El Capitan but I don't think it matters.

  • 1
    Don't worry, your data isn't lost! Read the above post by Stephane Bracket! I do not understand it, but I reinstalled El Capitan OSX and all my data was still intact. Thank you! – R M Jul 23 '17 at 2:31
1

After an entire day, we've gotten it done! I made some changes. I left out config, I implemented the kextd.plist(like you suggested) and ended with /usr/libexec/repair_packages --repair --standard-pkgs(I got that from another post here, somewhere?), instead of diskutil repairPermissions /. diskutil just kept hanging. The final order was as follows:

fsck -fy
mount -uw
launchctl load /System/Library/LaunchDaemons/com.apple.notifyd.plist
launchctl load /System/Library/LaunchDaemons/com.apple.DiskManagementd.plist
launchctl load /System/Library/LaunchDaemons/com.apple.securityd.plist
launchctl load /System/Library/LaunchDaemons/com.apple.kextd.plist
launchctl load /System/Library/LaunchDaemons/com.apple.DiskArbitrationd.plist
/usr/libexec/repair_packages --repair --standard-pkgs
exit

Everything went perfectly and I am now sending this message from my newly restored MacBookPro!

  • @klanomath - I know we're not supposed to say thank you here, but we can't send emails on this site(that I know of) and I can't chat. So, I'll delete this whenever it lets me. THANK YOU SO MUCH! Really, I can't thank you enough. And whoever edited/fixed my sloppy post and made it look exactly how I WANTED it to, thank you too. Klanomath, you're patient and kind and awesome. Thank you for all of your help! It was you who edited my answer! Perfect! Thank you! – Honeybee0919 Oct 14 '15 at 14:21
  • 1
    You're welcome ;-) Did you just restore the previous state of the MBP with the help of repair_packages? Or did you reinstall the whole system after backing up your stuff? BTW I edited your post. And what do you want to delete? Your answer or the comment? – klanomath Oct 14 '15 at 14:57
  • The comment. They keep saying not to say "thank you" or put anything that isn't strictly business. I kind of figured it was you who fixed my answer(I just couldn't do it at 4 or 5am)! So, after typed "exit," it booted up(without getting stuck anywhere) and went through the whole OS X set up(country, time zone, etc)....At that point, I just figured it was going to erase everything, but it just added me as the admin and when I opened it up, the other accounts were all still there. You literally fixed the whole thing! I'm not sure if EVERY file is there, but they seem to be! – Honeybee0919 Oct 14 '15 at 15:09
  • 1
    I recommend backing up your data to an external drive and reinstall 10.6.8 or just installing a newer OS X like 10.7 to be on the save side. I doubt that the repair_packages command issued repaired everything. – klanomath Oct 14 '15 at 15:17
  • 1
    Better ask here next time before deleting obscure users or groups... ;-) – klanomath Oct 14 '15 at 16:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .