21

I would like to disable Shift+Command+Q keyboard shortcut for Log Out.

I am using Karabiner at the moment, but I only managed to disable it completely using the following xml:

<?xml version="1.0"?>
<root>
    <item>
        <name>Disable COMMAND SHIFT Q for Logout</name>
        <identifier>disable_CMD_SHIFT_Q_private</identifier>
        <autogen>__KeyToKey__ KeyCode::Q, VK_SHIFT | VK_COMMAND | ModifierFlag::NONE, KeyCode::VK_NONE</autogen>
    </item>
</root>

but I would like to have the keyboard combination available in emacs (in ESS for debugging).

Is there some way that I can effectively unmap the keyboard combination?

2 Answers 2

23

The following works for me on 10.9.5:

  1. System Preferences > Keyboard > Shortcuts > App Shortcuts.
  2. '+' to add a shortcut
  3. Application: All Applications
  4. Menu Title: Log Out [Your Name]… Here, copy the exact text shown in the Apple menu, replacing [Your Name], and note that the ellipsis must be typed with alt-;
  5. Keyboard Shortcut: ctrl-shift-cmd-Q (or whatever you prefer: something different to shift-cmd-Q)
  6. Log out and in again.
  7. Note that the keyboard shortcut has changed in the Apple menu, and shift-cmd-Q no longer triggers the menu.
6
  • Works perfectly. Very good to remember that the system shortcuts can be modified even if they are not visible in Preferences > Keyboard > Shortcuts.
    – Rainer
    Oct 13, 2015 at 8:58
  • Works for me as well on Yosemite (10.10.5)
    – Steven
    Apr 7, 2016 at 18:26
  • 2
    This is not working for me on Sierra. I ensured the text is identical, and actually tried both regular ... and Alt key combination. But shortcut remains the same, unfortunately. Aug 29, 2017 at 13:10
  • 4
    I was able to get this to work on High Sierra by doing the above for BOTH Log Out <Your Name> and Log Out <Your Name>…. Weirdly enough, by default High Sierra shows just Log Out <Your Name>…. If you override this shortcut as described, another item appears in the "Apple" menu, this time without the ellipsis: Log Out <Your Name>, and having the same cmd_shift_q shortcut. Only when you override this second item can you truly free up cmd_shift_q. Mar 6, 2018 at 20:51
  • Works for me on Catalina 10.15.5. I used this technique to enable control-command-Q as a shortcut in iTerm2.
    – Sam Dutton
    Jul 21, 2020 at 17:54
0

You can't disable it because it is system shortcut. But you can add another shortcut over it. I found useless command to link with shift+command+Q.

  1. Go System Preferences / Keyboard / Shortcuts

enter image description here

  1. Select Accessibility and activate Zoom section by clicking box.

enter image description here

  1. Select "Turn focus following on or off" and hit the "Add Shortcut" button.

enter image description here

  1. Add shift+command+Q command to this shortcut.

enter image description here

You done.

Now shift+command+Q shortcut is useless.

Source https://discussions.apple.com/thread/7634486

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .