After I installed el Capitan, Little Snitch started complaining about gamed trying to phone home. Research in the net revealed various suggestions, including

  • logging out from the Game Centre
  • using launchctl unload
  • sudo defaults write /System/Library/LaunchAgents/com.apple.gamed Disabled -bool true
  • adding <key>Disabled</key><true/> to gamed's plist
  • rename the gamed image
  • etc.

OK. I wasn't logged into the Game Centre. launchctl unload isn't pervasive across reboots (nor is the cruder killall -9 gamed). sudo default write... had no effect.

So I sudo'ed into /System/Library/LaunchAgents and tried to edit com.apple.gamed.plist. Try as I would, I couldn't get write permission for the file. The same happened when I tried to rename the gamed image.

What has Apple done to permissions? There don't seem to be any special ACLs on /System/Library/..., but root cannot change files for which root has rw permissions. (This explains presumably why sudo default write... had no effect.)

Has anyone else seen this? Is there any way round it?



1 Answer 1


OS X 10.11, El Capitan, introduced System Integrity Protection (SIP).

The contents of /System and a few other paths are now protected and can not be edited. Even root user can not edit the contents of these paths.

You can disable SIP but it is generally not recommended:

  1. Reboot your Mac into Recovery Mode by restarting your computer and holding down Command+R until the Apple logo appears on your screen.
  2. Click Utilities > Terminal.
  3. In the Terminal window, type in csrutil disable and press Enter.
  4. Restart your Mac.

Not the answer you're looking for? Browse other questions tagged .