5

I have reformatted my MBPr/MBP (have both) multiple times and now, they are also appearing multiple times on my iPhone (Setting => iMessage => Text Forwarding).

Any ideas on how to remove duplicate/unused ones? Thank you

2
  1. Go to the iCloud website.
  2. Log in and click on Settings.
  3. Scroll down to My Devices

From there, you should be able to click on any of the devices registered to your account and delete them. Good luck!

| improve this answer | |
  • Oddly, when I look at "My Devices", I only see a single instance of the duplicated system (that appears on the iPhone "Text Forwarding" list. Deleting it had no effect on the multiple instances listed on the iPhone. – jhfrontz May 16 '16 at 14:41
  • I'm in the exact same situation and this answer was absolutely no help, just as @jhfrontz wrote. Strange that it's the accepted answer. – JVC Mar 15 '18 at 0:20
5

If you reset your iCloud password, the old services will be removed from: Settings > Messages > Text Forwarding

| improve this answer | |
  • 1
    I can confirm that this works unlike any of the other answers. – cyberwombat Jan 5 '19 at 21:04
0

Let me know if I'm not understanding your question correctly, but here are 3 interpretations of what I think you're asking, along with solutions to each.

1.) You want messages you delete/read on one device to also be deleted/read on all the others:

  • All messages in blue bubbles represent iMessages, meaning, they're controllable within the iCloud ecosystem. So they'll work like IMAP - if you delete it once, it'll delete it everywhere. So you should have no problems there.
  • If it's the green bubble messages you're having problems with (SMS), disable receiving SMS on your mac by opening your iPhone settings: Settings -> Messages -> Text Message Forwarding, and turn off your enabled device/s.

Note: this will disable the ability to send SMS from your Mac via your iPhone, but it shouldn't debilitate you too much since you can still send SMS from the iPhone itself. Again, if the receiver also uses an Apple Device, you'll still be able to send them iMessages from either iPhone or Mac.

2.) If you're experiencing "grouped" messages, when the only people in the group are you and the person you're sending a message to:

  • Check that you have your MMS Email Address entered on your iPhone (yes, I know this is a Mac question, but this is a real fix.)
  • Settings -> Messages -> MMS Email Address
  • If you don't know your MMS email address (the one provided by your mobile service provider), here is a list for the big three:
  • Verizon = YOURNUMBER@vtext.com
  • AT&T = YOURNUMBER@mms.att.net
  • Sprint = YOURNUMBER@messaging.sprintpcs.com.

3.) If you're wanting to receive text to just one device instead of all devices:

  • On your Mac, open Messages -> Preferences -> Accounts -> iMessage (displayed as your Apple ID), and uncheck "Enable this account".

HOPE THAT HELPS!

| improve this answer | |
0

I also had multiple macbooks showing in my "Text Message Forwarding" preference screen, it was showing 7 macbooks even though there were only 2 on the "Manage your APPLE Id" web page.

Although I was unsuccessful in removing them from the text message pref screen, I did discover that since activating any of them requires you to type in the code shown on your macbook, it becomes clear which one is the macbook you want to connect with, because either the mac opens the messages app and shows you a code, or it doesn't and you just deselect that device from the app and try the next one!

As a tip it's worth trying the bottom device first, as that was the one for me—presumably because they're in order of when they were first set up, so it was the latest one I'd signed in to.

| improve this answer | |
0

Change your iCloud password and that's it.

| improve this answer | |
  • It sounds like this actually works, but it would be awesome if this answer could help explain why. – Nic Mar 15 at 21:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .