I just updated my iPhone to iOS 9.0.2, then I want to define some words. When I clicked the 'define' button, there's nothing appear. But, before I updated to iOS 9.0.2, I still can use the define button. So what should I do to allow it to define the words I want?

3 Answers 3


Go to Settings -> General -> Language & Region -> and make sure the languages you want your iPhone to recognize are in the "Preferred Language Order" list.

If the language you prefer is already in that list, tap "edit" to delete the language, and then add it back up. This should add the language's dictionary and enable the "define" function.

  • It still doesn't work. I click 'manage' and saw the blue circle beside the language which is English-British, English-America, and Apple Dictionary. What is the meaning of the blue circle??? Oct 12, 2015 at 12:22
  • I just click on the other language and it's work !! I try to delete them and download them back. I hope it works. Oct 12, 2015 at 12:38
  • Okay it works !! All I have to do is manage it back. Delete them and reupload it. Then I try to define it back and it works !! Thanks btw Oct 12, 2015 at 12:42
  • Awesome :). I've edited my answer to include deleting the language and then adding it again. If you could upvote my answer, I'd greatly appreciate it!
    – saphryn
    Oct 13, 2015 at 14:43

Go to Settings->General->Reset->Reset Keyboard Dictionary.

Tried every other suggestion, this works.


High light the word, his define then hit manage. Download the dictionary in the language you want from there and try again. Should work

  • Hitting manage shows nothing but a blank page with lines like ruled paper.
    – Deesbek
    Aug 5, 2016 at 21:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .