So today, I tried dual-booting my late 2013 rMBP on El Capitan with Windows 10. I got to the step within Bootcamp where it was partitioning my SSD, and I went ahead and played a game of Super Smash. After the round was over, I found that my Macbook had restarted because of an issue. I don't know what the issue was, and I don't know why the computer restarted, but I think it messed with my drive sizes. When I open Disk Utility, I see that the computer recognizes that I have a 250 GB SSD, but the Macintosh HD area seems to be "partitioned" for 204 GB. I have included pictures for clarification. What the computer says about my SSD. This is what the mac says about my SSD. Macintosh HD Here is what the Macintosh HD looks like. If I'm not mistaken, shouldn't the Macintosh HD size be the same as my SSD? How can I fix this, as I'm unable to find any tutorials to help me. I have tried to partition the SSD to try to be able to merge them, but I get an error saying: "The provided Core Storage logical volume has an incorrect size. You should run whole-disk repair." I have run diskutil in terminal to find no information that is useful to me, but I have included it here in case it helps someone help me. diskutil list:

/dev/disk0 (internal, physical):
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:      GUID_partition_scheme                        *251.0 GB   disk0
1:                        EFI EFI                     209.7 MB   disk0s1
2:          Apple_CoreStorage Macintosh HD            250.1 GB   disk0s2
3:                 Apple_Boot Recovery HD             650.1 MB   disk0s3
/dev/disk1 (internal, virtual):
#:                       TYPE NAME                    SIZE       IDENTIFIER
0:                  Apple_HFS Macintosh HD           +204.0 GB   disk1
                              Logical Volume on disk0s2
                             Unlocked Encrypted

diskutil cs list:

CoreStorage logical volume groups (1 found)
+-- Logical Volume Group A7C277C4-D35C-48A1-AD85-135FC3FBBAAE
Name:         Macintosh HD
Status:       Online
Size:         250140319744 B (250.1 GB)
Free Space:   45788061696 B (45.8 GB)
+-< Physical Volume 3A4B651C-DA22-4F22-96F3-A1C3D22BCE45
|   ----------------------------------------------------
|   Index:    0
|   Disk:     disk0s2
|   Status:   Online
|   Size:     250140319744 B (250.1 GB)
+-> Logical Volume Family DBA55F9D-7D02-4191-B9C2-1CC1CB429E3C
    Encryption Type:         AES-XTS
    Encryption Status:       Unlocked
    Conversion Status:       Complete
    High Level Queries:      Fully Secure
    |                        Passphrase Required
    |                        Accepts New Users
    |                        Has Visible Users
    |                        Has Volume Key
    +-> Logical Volume FEB0DA59-F214-4841-A491-59BFE7F9DEE4
        Disk:                  disk1
        Status:                Online
        Size (Total):          203999936512 B (204.0 GB)
        Revertible:            Yes (unlock and decryption required)
        LV Name:               Macintosh HD
        Volume Name:           Macintosh HD
        Content Hint:          Apple_HFS

Is there a way I can get back the usable space onto Macintosh HD? Is there a method if I were to wipe the hard drive (and how) and start from scratch? Thanks in advance for any help.


Your main CoreStorage container has a size of 250.1 GB with 45.8 GB of unallocated container disk space.

Usually you can expand the size of a Logical Volume to the full size of the Logical Volume Group if no other blocking Logical Volumes exist in the same group.

This is done with the command:

diskutil cs resizeVolume lvUUID size

In you case that's:

diskutil cs resizeVolume FEB0DA59-F214-4841-A491-59BFE7F9DEE4 250g

If the Logical Volume is encrypted it has to be unlocked.

Failing to change the disk layout with Boot Camp Assistant often corrupts internals of the Logical Volume Group and the above command fails. Then you have to remove the Logical Volume Group and restore a Time Machine backup to an erased and JHFS+ formatted disk0s2 partition


It depends! If the free space physically before the Macintosh HD then you need to backup and restore. This is quite difficult, and not really recommended.

Did you try to "run whole-disk repair". This would probably need to be run from a Revovery console; hold ⌘+R while rebooting.

The answer to a question I asked may help. https://apple.stackexchange.com/a/209401/19086 If you can't resize you could try adding the free space to the Logical Volume Group.


Since there is only a partition on your drive seen by macOS, you should be able to make a new partition with BootCamp Assistant. Make it of minimum size, it should "eat" all the free space on your drive. Then you can restore all of it via BootCamp Assistant. That worked for me, I restored 502GB on my 3TB Fusion Drive.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Can you provide a more detailed explanation of what you actually did in the different steps? – nohillside Jul 1 '18 at 8:52
  • As I said, I just made a new partition via bootcamp. The resulting size of this partition will be - and was for me - [GB you set + hidden unallocated space on your HDD]. By erasing it, via Bootcamp again, you will restore the entire disk capacity. – Sir Whitelight Jul 22 '18 at 17:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .