4

Apple Mail app crashes for me nonstop after I updated to El Capitan. Every time just a one or two right after opening.

I started to have this problem right after I installed El Capitan to clean HD and migrated within Migration assistant my old account and settings (everything except of applications).

Would be nice if someone could help me with that..Thank you! Here I am copying the beginning of text from the crash report-Crash is at Thread 22 (it is not whole text because of restriction of limited number of characters(if needed I will send it via email)):

Process:               Mail [11820]
Path:                  /Applications/Mail.app/Contents/MacOS/Mail
Identifier:            com.apple.mail
Version:               9.0 (3094)
Build Info:            Mail-3094000000000000~1
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Mail [11820]
User ID:               502

Date/Time:             2015-10-11 22:25:22.716 +0200
OS Version:            Mac OS X 10.11 (15A284)
Report Version:        11
Anonymous UUID:        8601D8B6-77BF-16F6-A40D-390BC39A2A45

Sleep/Wake UUID:       2F46000D-690E-43A0-846B-4E7AAF410C31

Time Awake Since Boot: 14000 seconds
Time Since Wake:       1200 seconds

System Integrity Protection: disabled

Crashed Thread:        22  Dispatch queue: Task Manager Serialization Queue :: NSOperation 0x7ff64d7c4930 (QOS: LEGACY)

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'Attempting to perform a synchronous operation while on the serialization queue'
abort() called
terminating with uncaught exception of type NSException

....
Thread 22 Crashed:: Dispatch queue: Task Manager Serialization Queue :: NSOperation 0x7ff64d7c4930 (QOS: LEGACY)
0   libsystem_kernel.dylib          0x00007fff95c880ae __pthread_kill + 10
1   libsystem_pthread.dylib         0x00007fff8797a500 pthread_kill + 90
2   libsystem_c.dylib               0x00007fff90fd137b abort + 129
3   libc++abi.dylib                 0x00007fff8f4bef81 abort_message + 257
4   libc++abi.dylib                 0x00007fff8f4e4a47 default_terminate_handler() + 267
5   libobjc.A.dylib                 0x00007fff8bdd608d _objc_terminate() + 103
6   libc++abi.dylib                 0x00007fff8f4e219e std::__terminate(void (*)()) + 8
7   libc++abi.dylib                 0x00007fff8f4e2213 std::terminate() + 51
8   libdispatch.dylib               0x00007fff8774d467 _dispatch_client_callout + 28
9   libdispatch.dylib               0x00007fff87752083 _dispatch_queue_drain + 754
10  libdispatch.dylib               0x00007fff877586c9 _dispatch_queue_invoke + 549
11  libdispatch.dylib               0x00007fff87750d9b _dispatch_root_queue_drain + 538
12  libdispatch.dylib               0x00007fff87750b48 _dispatch_worker_thread3 + 91
13  libsystem_pthread.dylib         0x00007fff879774f2 _pthread_wqthread + 1129
14  libsystem_pthread.dylib         0x00007fff87975375 start_wqthread + 13
1
2

There is a good work around for this, that can be found on the apple discussion forum, here: https://discussions.apple.com/thread/7251820

Should you be in the same position as the author of this, and have multiple mail accounts active, try the following steps:

I had the same problem, but I believe I've fixed it. It's seems to have been related to the fact that I have multiple email accounts active in the app, as many people do. The initial download of all messages from all accounts seemed to be overloading the app, causing it to crash. See if this works for you:

  1. Before opening the Mail app, turn off your wifi connection (prevents mail from trying to download mailboxes from all accounts at once).
  2. Launch Mail app and go to Mail -> Preference -> Accounts tab.
  3. Click each of your accounts on the left side of the Accounts window, then uncheck the box next to "Enable this account." Disable all of your mail accounts.
  4. Close Preference and close the Mail app.
  5. Relaunch the mail app and reconnect to wifi.
  6. Go back to Mail -> Preferences -> Accounts tab, and enable the first account. Give the app plenty of time to download all messages until you no longer see "Checking for Mail..." at the bottom left of the app screen (may take a few minutes depending on how many messages you have on the server).
  7. Once the app is no longer "Checking for Mail..." repeat this server for each of your other accounts. I saved Gmail until last since it's my biggest, which took the longest - about 5 minutes (I use multiple Gmail accounts).

After enabling all accounts, the crash issue stopped for me. Hope it works for you!

3
  • 1
    Any feedback whether this works? – VH-NZZ Nov 27 '15 at 8:56
  • @okiharaherbst For me it does not work. But the one in: apple.stackexchange.com/questions/201201/… does. – Piotr Migdal Dec 23 '15 at 21:34
  • Worked for me, albeit in my case Mail was crashing whenever I've tried to open Preferences. The key point was to disconnect from network and relaunch. – badbishop Mar 13 '16 at 12:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .