5

Since enabling iCloud sync for the Notes.app in a preview beta of El Capitan, the app started to crash every time I open it.

I've tried removing the plist file, the com.apple.Notes folder from ~/Library/Caches, and even the container, but the result is the same.

  1. Has anyone else run into this issue?
  2. Any suggestions on how to fix it?

Update: the app crashed even when iCloud sync is disabled.

Update 2: I've ended up doing a clean install. By now I'm convinced that once something went wrong when enabling iCloud sync, there's no good solution of fixing this issue.

Crash report

```

Process:               Notes [3281]
Path:                  /Applications/Notes.app/Contents/MacOS/Notes
Identifier:            com.apple.Notes
Version:               4.0 (535)
Build Info:            Notes-535000000000000~8
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Notes [3281]
User ID:               501

Date/Time:             2015-10-10 19:57:35.215 -0700
OS Version:            Mac OS X 10.11.1 (15B30a)
Report Version:        11


System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000018
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x18:
--> 
    __TEXT                 0000000107a4e000-0000000107bc0000 [ 1480K] r-x/rwx SM=COW  /Applications/Notes.app/Contents/MacOS/Notes

Application Specific Information:
objc_msgSend() selector name: hash
Performing @selector(changeFont:) from sender NSFontManager 0x7fb9a1d3b5c0

Global Trace Buffer (reverse chronological seconds):
24.904044    NotesShared                0x00007fff90939e15 Saving versioned document 0 with 0 future versions.
24.904719    NotesShared                0x00007fff90939e15 Saving versioned document 0 with 0 future versions.
47.464360    CFNetwork                  0x00007fff92210a0f TCP Conn 0x7fb9a42a7a50 complete. fd: 32, err: 0
47.464449    CFNetwork                  0x00007fff9229f1ad TCP Conn 0x7fb9a42a7a50 event 1. err: 0
61.375901    CFNetwork                  0x00007fff92212163 TCP Conn 0x7fb9a40e4d70 SSL Handshake DONE
61.483867    CFNetwork                  0x00007fff9221203f TCP Conn 0x7fb9a40e4d70 starting SSL negotiation
61.484253    CFNetwork                  0x00007fff92210a0f TCP Conn 0x7fb9a40e4d70 complete. fd: 23, err: 0
61.484560    CFNetwork                  0x00007fff9229f1ad TCP Conn 0x7fb9a40e4d70 event 1. err: 0
61.550260    CFNetwork                  0x00007fff9220fcdf TCP Conn 0x7fb9a40e4d70 started
61.627147    CFNetwork                  0x00007fff921d386b Creating default cookie storage with default identifier
61.627147    CFNetwork                  0x00007fff921d3836 Faulting in CFHTTPCookieStorage singleton
61.627147    CFNetwork                  0x00007fff921d36c5 Faulting in NSHTTPCookieStorage singleton

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libobjc.A.dylib                 0x00007fff8dd9de5d objc_msgSend + 29
1   com.apple.Foundation            0x00007fff82c96684 -[NSConcreteMapTable objectForKey:] + 42
2   com.apple.UIFoundation          0x00007fff84b8389d +[__NSFontTypefaceInfo typefaceInfoForPostscriptName:options:] + 155
3   com.apple.UIFoundation          0x00007fff84b8a677 __NSGetMetaFontInstance + 1099
4   com.apple.NotesShared           0x00007fff908cd5f1 -[TTTextController styleForModelAttributes:] + 486
5   com.apple.NotesShared           0x00007fff908cc795 -[TTTextController typingAttributesForRange:forSelectionChange:currentTypingAttributes:inTextStorage:] + 185
6   com.apple.Notes                 0x0000000107b1a248 0x107a4e000 + 836168
7   com.apple.AppKit                0x00007fff830de192 -[NSTextView(NSSharing) setTypingAttributes:] + 289
8   com.apple.Notes                 0x0000000107a8522a 0x107a4e000 + 225834
9   com.apple.AppKit                0x00007fff830dd423 -[NSTextView(NSPrivate) _addToTypingAttributes:value:] + 236
10  com.apple.AppKit                0x00007fff83438a49 -[NSTextView changeFont:] + 881
11  com.apple.Notes                 0x0000000107a8a9c7 0x107a4e000 + 248263
12  libsystem_trace.dylib           0x00007fff8a596082 _os_activity_initiate + 75
13  com.apple.AppKit                0x00007fff83285811 -[NSApplication sendAction:to:from:] + 460
14  com.apple.AppKit                0x00007fff8343866e -[NSFontManager sendAction] + 93
15  com.apple.AppKit                0x00007fff83442ec2 -[NSFontManager modifyFontViaPanel:] + 83
16  com.apple.AppKit                0x00007fff83442dae -[NSFontPanel _setFont:] + 72
17  com.apple.AppKit                0x00007fff8344488b -[NSFontPanel _chooseFamily:] + 771
18  libsystem_trace.dylib           0x00007fff8a596082 _os_activity_initiate + 75
19  com.apple.AppKit                0x00007fff83285811 -[NSApplication sendAction:to:from:] + 460
20  com.apple.AppKit                0x00007fff83297a0e -[NSControl sendAction:to:] + 86
21  com.apple.AppKit                0x00007fff83316ef5 -[NSTableView _sendAction:to:row:column:] + 111
22  com.apple.AppKit                0x00007fff8331574f -[NSTableView mouseDown:] + 6308
23  com.apple.AppKit                0x00007fff83443eba -[NSFontPanelTableView mouseDown:] + 190
24  com.apple.AppKit                0x00007fff837e242d -[NSWindow _handleMouseDownEvent:isDelayedEvent:] + 6322
25  com.apple.AppKit                0x00007fff837e3411 -[NSWindow _reallySendEvent:isDelayedEvent:] + 212
26  com.apple.AppKit                0x00007fff83228b8d -[NSWindow sendEvent:] + 517
27  com.apple.AppKit                0x00007fff831a8b27 -[NSApplication sendEvent:] + 2540
28  com.apple.AppKit                0x00007fff8300fd9a -[NSApplication run] + 796
29  com.apple.AppKit                0x00007fff82fd8fbe NSApplicationMain + 1176
30  libdyld.dylib                   0x00007fff9255d5ad start + 1

External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 1
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 2953
    thread_create: 0
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=318.6M resident=0K(0%) swapped_out_or_unallocated=318.6M(100%)
Writable regions: Total=1.1G written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=1.1G(100%)

                                  VIRTUAL   REGION 
REGION TYPE                          SIZE    COUNT (non-coalesced) 
===========                       =======  ======= 
Accelerate.framework                 256K        3 
Activity Tracing                    2048K        2 
CG backing stores                   1160K        3 
CG image                             532K       54 
CG shared images                     304K        8 
CoreAnimation                       23.0M       80 
CoreData Object IDs                 4100K        3 
CoreUI image data                   2836K       42 
CoreUI image file                    512K        9 
Dispatch continuations              8192K        2 
Foundation                            40K        3 
Image IO                               4K        2 
JS JIT generated code                  8K        3 
JS JIT generated code (reserved)     1.0G        2         reserved VM address space (unallocated)
Kernel Alloc Once                      8K        3 
MALLOC                              56.5M       50 
MALLOC guard page                     32K        7 
Memory Tag 242                        12K        2 
OpenCL                                 8K        2 
Process Corpse Info                 2048K        2 
SQLite page cache                    384K        4 
STACK GUARD                         56.0M       13 
Stack                               13.1M       15 
VM_ALLOCATE                          112K       16 
WebKit Malloc                       4320K       10 
__DATA                              33.8M      343 
__IMAGE                              528K        2 
__LINKEDIT                          88.3M       29 
__TEXT                             230.2M      354 
__UNICODE                            552K        2 
mapped file                         95.9M       40 
shared memory                       16.3M        8 
===========                       =======  ======= 
TOTAL                                1.6G     1086 
TOTAL, minus reserved VM space     640.7M     1086 

Model: MacBookPro10,2, BootROM MBP102.0106.B0A, 2 processors, Intel Core i5, 2.5 GHz, 8 GB, SMC 2.6f59
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3831554738454255302D474E2D4620
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3831554738454255302D474E2D4620
  • I suggest signing out of iCloud completely and rebooting your Mac after that. Check if that helps. – Behdad Oct 18 '15 at 17:31
1

I had the same issue but fixed it by:

  • deselecting iCloud sync for Notes
  • opening Notes
  • reselecting iCloud sync

So far so good...it crashed after ~5 sec before, now all appears well.

  • Unfortunately it still crashed but this time with a different stack trace. – Alex Popescu Oct 12 '15 at 1:30
  • This fixed my issue after upgrading in Sierra – y3sh Sep 21 '16 at 14:18
1

In my case was Safari that closed randomly for weeks. I resolved it by doing the following

  1. Delete Safari with AppCleaner

  2. Mount OS X recovery partition with

    diskutil mount Recovery\ HD hdiutil mount /Volumes/Recovery\ HD/com.apple.recovery.boot/BaseSystem.dmg cp -R /Volumes/OS\ X\ Base\ System/Applications/Safari.app /Applications
    
  3. Install Pacifist then open OS X Installer and install Safari with Pacifist.

  4. In iCloud disable Safari and then enable it

  • Welcome to Ask Different! As this does not answer the question (in this case, the OP was asking about issues with a Notes app, however your answer is in relation to Safari not working), I am flagging it for deletion. – Charlie74 Dec 14 '15 at 17:08
1

I had this issue with TextEdit and Preview. Deleting the com.apple.xxx files in ~/Library/Preferences/ and ~/Library/Components as suggested on other forums didn't help. At best it solved the issue for a couple of days.

Problem was coming from wrong permissions on some font files. Repairing permissions on the Fonts folder solved my issue. Open Terminal and type

sudo /usr/libexec/repair_packages --repair --standard-pkgs /Library/Fonts/

You will be asked for your password (sudo means get super user powers) Repairing permissions used to be available from the Disk Utility app but Apple removed it since Mavericks or Yosemite for some reason.

1

As with most of you, I just had the same issue. I combined a couple of different suggestions (e.g., Capt G) from this thread to find a solution for me:

  1. Open Internet Accounts
  2. Select the "Exchange" account if you have one set-up.
  3. Uncheck the Notes app in the window to the left showing the apps associated with the Exchange account. Keep this window open.
  4. Open Notes. Notes stayed open for me, with just the iCloud data available.
  5. Close Notes.
  6. Now, in the Internet Accounts window check the Notes app in the window to the left associated with the Exchange account.
  7. Open Notes. This time the Notes app stayed open for me with all my original data.

I hope this helps!

1

Finally found a solution for this after months of trying various different things. (Tried pretty much every solution, individually or in combination). What finally worked for me was:

Making sure that all internet accounts had synching off for notes (including iCloud) in the system preferences Going to /users/[name]/Library and doing a search within that folder for any file containing “Notes” in the name. matches were found in both /users/[yourname]/Library/Containers AND /users/[yourname]/Library/GroupContainers going to /Library/Caches and selecting all and moving to trash Selected all such files, threw them in the trash. Empty trash Reboot Open Notes Turn on synching for iCloud

Presto! It worked! For the first time since I installed Sierra pretty much, it finally worked on my computer again! So I’m not sure which file it was exactly that I deleted that did the trick, but my best guess is that deleting the notes related files in “containers” is not enough, you must also go after the related files in “group containers”.

There we go! Hope this helps somebody else!

  • You are life saver, your solution works like charm. Thank you. – Eldwin Eldwin Apr 15 '17 at 8:20
0

Same for me. Under El Capitan, on one of my Macs, Notes crashes every time that I try to open it. I tried turning off iCloud synch, but that did not help; Notes keeps crashing.

Next time I reboot, I will trying running Notes in Safe Mode -- for the first time only! -- to see if I then can open it up normally thereafter in regular mode.

Have you tried that, anyone?

0

Solution: Remove MS exchange account in internet accounts. Notes app will not crash upon opening then add your MS exchange account again.

0

No solution from me.

Notes.app still crashes. My issues seem to relate to fonts. The Font Repair process didn't fix it.

If I have an unusual font, it crashes. If I change the first line of text to a Heading, it might crash. If I try to print, it might crash. Frequently it fails to pop-up the Print dialogue.

Moving to Evernote or equivalent.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .