Just a quick question, is NTFS supported on El Capitan? I just plugged in my external hard drive and I am able to copy stuff from it, but not write to it. I guess only read mode is supported?

  • 1
    US$20 gets you Paragon NTFS. For US$31, Tuxera NTFS for Mac will do NTFS. I don't use either, but I have a colleague who uses Paragon.
    – IconDaemon
    Commented Oct 10, 2015 at 13:45
  • 2
    NTFS Write Support actually exists in OS X however it's turned off by default, probably because of a licensing issue, and an appropriate entry to /etc/fstab and the NTFS volume would be writable. That said the native write support is slower then the third-party utilities mentioned by IconDaemon. I personally use Tuxera NTFS for Mac, although I keep write-support disabled and only enable it when needed, as it's easily done through Tuxera NTFS in System Preferences. One thing to be concerned about is any filesystem corruption on the NTFS volume, there are no OS X native utilities to repair. Commented Oct 10, 2015 at 14:39
  • I use Paragon NTFS and it's good.
    – Pratik
    Commented Jan 4, 2016 at 1:47

4 Answers 4


Newer macOS

See updated answer at https://apple.stackexchange.com/a/213575/62697.

Older macOS

To enable NTFS write support on OS X 10.11 El Capitan or macOS 10.12 Sierra.

  1. Install latest osxfuse (3.x.x) from https://github.com/osxfuse/osxfuse/releases. (you don't need MacFUSE Compatibility Layer) or from Homebrew with brew cask install osxfuse.

  2. Install latest NTFS-3G (2016.2.22) from Homebrew. (you need Xcode)

As follow:

brew install ntfs-3g
  1. Link NTFS-3G to boot after temporary disabling System Integrity Protection.

As follow:

[reboot by holding CMD+R to get in recovery mode]
csrutil disable
[reboot normally]
sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original
sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs
[reboot by holding CMD+R to get in recovery mode]
csrutil enable
[reboot normally]

You will get those instructions from this wiki page as well: https://github.com/osxfuse/osxfuse/wiki/NTFS-3G

  • These steps are just great. They worked like a charm...only thing I notice is that, when copying a bunch of files (more than 10 Gb) to an external NTFS-formatted hard drive, I noticed that it is way slower than Tuxera NTFS for Mac...bad thing is that latest version of that is not free (as it used to be some time ago) @Cœur Did you notice this? If so, any way to fix it? Thanks! Commented Nov 1, 2015 at 18:39
  • 1
    @Jonathan You can try to build NTFS-3G from source edge: stackoverflow.com/a/31014256/1033581
    – Cœur
    Commented Nov 2, 2015 at 0:32
  • 1
    this answer is worked!, NOTE: you need to type csrutil in recovery mode > terminal, and copy sudo line 1 by 1 Commented Jan 11, 2016 at 12:36
  • Didn't work for me. I did a brew install homebrew/fuse/ntfs-3g, and after rebooting into recovery mode, I disabled csrutil. Then I booted back into normal mode, made the symlink, and then enabled csrutil in recovery mode. Now in normal mode, it won't even detect my external drive [NTFS]. Earlier it used to mount as read-only, but now I don't see anything in the finder. Also, the sudo dmesg output is flooded with lines like Sandbox: coresymbolicatio(1283) System Policy: deny(1) file-write-unlink /System/Library/Caches/com.apple.coresymbolicationd/data. Any help? @Cœur Commented Sep 27, 2016 at 15:28
  • @reza.safiyat, no, didn't face this issue, so can't help.
    – Cœur
    Commented Sep 28, 2016 at 3:25

Not just in El Capitan. That's been the standard behaviour of OS X in regards to NTFS since at least 10.4 (which is the first version I used): you can read, but you can't write.

In addition to the solutions mentioned above, you can also try NTFS-3G. Or, if you want to go the other way, there's an app called MacDrive for Windows which allows your PC to read Mac-formatted disks.


For those who get an error while installing homebrew/fuse/ntfs-3g saying:

Error: The brew link step did not complete successfully

The formula built, but is not symlinked into /usr/local. Removing files returns an error like:

Error: Could not symlink include/ntfs-3g/acls.h /usr/local/include/ntfs-3g is not writable.

Solution that worked for me posted by bfontaine:

sudo chown -R $(whoami):admin /usr/local; brew link --overwrite ntfs-3g



Write to NTFS on OSX Yosemite and El Capitan

Step 1

Install osxfuse (3.x.x) from https://github.com/osxfuse/osxfuse/releases.

Step 2 Install Homebrew: (run below command in terminal)

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

Step 3 Update Homebrew formulae: (run below command in terminal)

brew update

Step 4 Install ntfs-3g (run below command in terminal)

brew install ntfs-3g

Step 5

If you are on OSX 10.11 (El Capitan), temporary disable System Integrity Protection.

Steps to disable the Integrity protection

There are four steps to disable :

1 - Reboot the Mac and hold down Command + R keys simultaneously after you hear the startup chime, this will boot OS X into Recovery Mode

2- When the “OS X Utilities” screen appears, pull down the ‘Utilities’ menu at the top of the screen instead, and choose “Terminal”

3- Type the following command into the terminal then hit return:

csrutil disable

4- You’ll see a message saying that System Integrity Protection has been disabled and the Mac needs to restart for changes to take effect,


and the Mac will then reboot itself, just let it boot up as normal

Step 6

Create a symlink for mount_ntfs

sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original 

sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs

Step 7

If you are on OSX 10.11 (El Capitan), re-enable System Integrity Protection.

follow step 5, only need to change the terminal command to

csrutil enable

Step 8

attach the hard disk cable to mac. its working.

  • How does this differ from the solution given by Coeur above?
    – nohillside
    Commented Dec 27, 2016 at 13:12
  • Thanks patrix for point. I added step by step solution so that a novice could understand what actually he/she is doing by using these steps. Commented Dec 27, 2016 at 13:22

Not the answer you're looking for? Browse other questions tagged .