I recently installed OS X 10.11 on my Mac.

I tried to read a SD card with an Ext4 partition which wasn't even shown in Disk Utility, although diskutil did show it as a Linux partition.

I can't seem to mount the partition (the mount command seems to have changed, but I haven't explored this fully).

I had FUSE for OS X installed and updated to 2.8.1. I also had fuse-ext2, but even though this was shown in Preferences, it shows "Not Installed". I tried to re-install from the sourceforge site, but got the following error:-

This package is incompatible with this version of OS X and may fail to install.

Has anyone any solution to allow Ext4 partitions to be mounted.

  • Hey, just wondering if you've found a solution to this problem ? – dhruvvyas90 Oct 13 '15 at 11:34
  • @dastaan I worked around my original task by mounting on a Linix machine. I have also installed a Linix OS (Ubuntu MATE) in a virtual machine and can mount Ext4 using a USB card reader (the internal reader can't seem to be accessed). Neither of these is entirely satisfactory; I am undecided whether to disable SIP. I don't see why Apple wants to stop me using my machine, or why it obstinately refuses to build in Ext4 support (as it did to NTFS for years) - at least this is open source. I still hope someone will build Ext4 support which works with SIP. – Milliways Oct 13 '15 at 11:56
  • Thanks for the quick response. Lemme do it by your method, at least for now. Btw I tried disabling SIP mode to see if it works. But couldn't get it working. – dhruvvyas90 Oct 13 '15 at 12:29

Try using ext4fuse.

ext4fuse This is a read-only implementation of ext4 for FUSE. The main reason this exists is to be able to read linux partitions from OSX. However, it should work on top of any FUSE implementation.

Basic usage, where N and M in /dev/diskNsM are the disk and partition numbers (such as 7 and 1) of your Ext4 ("Linux") data. You can find these appropriate numbers for your machine in OS X' Disk Utility.

mkdir -p "$HOME/tmp/my-linux-mount"
ext4fuse "/dev/diskNsM" "$HOME/tmp/my-linux-mount"

On macOS Sierra the option -o allow_other is needed, as in:

ext4fuse /dev/diskNsM $HOME/tmp/my-linux-mount -o allow_other

Install both ext4fuse and osxfuse using Homebrew.

brew cask install osxfuse
brew install ext4fuse

According to the docs, you might also have to add <your user> to the operator group. Here using whoami to find your current username.

sudo dscl . append /Groups/operator GroupMembership "$(whoami)"

See also the fix for problems clicking "allow" for the "System Extension Blocked" message for osxfuse, and the osxfuse docs for mount options, such as allow_other and defer_permissions.

  • 5
    Thanks for this answer! Very useful. I had to use sudo ext4fuse /dev/diskNsM ~tmp/my-linux-mount -o allow_other to mount it before I was able to open it with my user... Wasn't able to open the disk without sudo on my system – Sean W. Feb 23 '17 at 21:44
  • 2
    Quick note here, :"quoting" ~/ in a command using zsh will actually create \~ folder instead of using home directory. Consider removing quotes or use $HOME instead. I confirm this works flawlessly on MacOS Sierra 10.12.3 :) – GabLeRoux Mar 19 '17 at 22:48
  • 1
    @GabLeRoux: quite right! Knowing how much copypasta happens on superuser, I kept the quotes but changed to $HOME. Thanks! – Joel Purra Mar 20 '17 at 6:45
  • This does not seem to be working properly, as indicated by some bug reports: github.com/gerard/ext4fuse/issues/44 – slhck Nov 28 '17 at 11:01
  • 1
    @JanM: from the ext4fuse readme: "If you use OS X I suggest you rely on the homebrew project." – Joel Purra May 1 at 6:09

Don't use Paragon ExtFS for OSX with El Capitan.The port is very experimental despite the fact that Paragon claims support for El Capitan.

I've damaged two times a 1.5TB ext4 filesystem beyond irreparable limits, using two independent installations of EL Capitan (10.11.3) on a MacBook Pro and MacBook Air. fsck -y /dev/sda(x) on an linux box after file transfer completed is claiming hundreds of thousands multiply-claimed blocks with several files and directories - filesytem gone!

ExtFs is also not implemented in DiskUtilty in Ela Capitan so you can't check the integrity of your filesystem nor format in ext2/3/4...

Paragon Guys please fix your software urgently! Your claim supporting El Capitan is very much misleading!

In Summary dump Paragon ExtFS with OSX 10.11.x and not waste your $20 or wind back to Yosemite or earlier OSX's. Alternatively put a Linux Box on your GB network and copy through SMB. It's safer....

  • This reads like a horror story! Have you had any subsequent dealings with Paragon's ExtFS since that would update this experience, or have you avoided using it since? I was considering it as an option, but this gives me legitimate concerns to read more before doing so. – TCAllen07 Mar 8 '17 at 23:00
  • I had a similar horror recently, but, fortunately, i was able to recover my files (only using windows tools). – nyxee Mar 30 '17 at 2:25
  • 3
    As horrible as it may be, this is not an answer to the question of how to read the ext4 partition on Mac. – Aleks G Jun 7 at 9:39

As discussed in fuse-ext2 / OSX 10.11 "El Capitan" make fails, installation of fuse-ext2 fails on OS X 10.11, El Capitan, due to System Integrity Protection (SIP).

The recommended solution right now is to disable SIP.

I have made a fork of fuse-ext2 which installs everything in /Library and /usr/local, so that you don't have to disable SIP in Mac OS X El Capitan. Glad if you try it ;-).

  • Looked interesting until I got to the Homebrew step. Is it possible for someone to make an installable package? – Milliways May 2 '16 at 7:48
  • 1
    Homebrew is needed only for e2fsprogs package (commands to make a new ext filesystem, do the check of an ext filesystem, etc). fuse-ext2 uses only the command e2label from efsprogs, to get the label of an ext volume. I think this is necessary for automatic mount at devices insertion (USB memory sticks, external hard drives, SD cards). If you are okay with manual mount, and don't need to make new ext filesystems or to check existing filesystems, you can leave out Homebrew and e2fsprogs installation. – gpz500 May 2 '16 at 8:50
  • And, if you already have an installation of e2fsprogs in your system (from MacPorts, from Fink or compiled from sources) you can edit the file /Library/Filesystems/fuse-ext2.fs/fuse-ext2.util in order to use your e2fsprogs installation. – gpz500 May 2 '16 at 9:01
  • at some point, while checkin my didsks, i was asked to install a newer version of e2fsck so i guess even those with older installations of e2fsprogs are advised to upgrade. – nyxee Mar 30 '17 at 2:32

Warning: Having experienced some of the same issues described in Schnorch's answer, I can no longer recommend this program! Original answer left below for posterity...

A commercial ($20) option is Paragon ExtFS for OS X, which supports read/write mounting of ext2/3/4. I'm using it now in El Capitan.

It has a few annoyances, such as seemingly not paying attention to mount options specified in fstab... But generally seems to do the job fine.

  • Where's fstab on OSX? I am using OSX 10.12. i can only access ext4 in read-only mode now. I recently lost my ext4 partitions but i'm still fighting with Paragon.. – nyxee Mar 30 '17 at 2:28
  • 1
    Just move to Linux... – danger89 Dec 30 '17 at 1:40

After visiting this page with this issue, this is what worked for me:

brew cask install osxfuse
brew install ext4fuse

Now you need to find your linux filesystem, so

diskutil list 

For me it had

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   5:           Linux Filesystem                         149.0 GB   disk0s5

Then following @Sean W.'s comment,

sudo ext4fuse /dev/disk0s5 ~tmp/my-linux-mount -o allow_other

And it should now be mounted.

  • 2
    This solution works, just tried it on my mac with an EXT4 external drive formatted by Synology NAS. Mounted fine. Thanks @Nicolas – James Wong Dec 21 '17 at 5:34
  • 1
    MacOS 10.13.3 blocks ext4fuse from running. I needed to go to security settings and allow software from developer 'Benjamin Fleischer' to run. Please make your own decision about whether this is a safe action to take. – Guy C Mar 25 at 12:51

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.