3

When trying to install software from App Store on OS X 10.11, I get the error message "The product distribution file could not be verified. It may be damaged or was not signed." I have tested several different pieces of software, and get the same issue on all of them.

I have found a few suggested solutions, however they are from 2011, and refers to the /var/folders, which El Capitan does not have (I can't remember when it disappeared, but I think it was some time ago).

In the system logs, I see the following each time I get the error:

09/10/15 19:28:04,476 storedownloadd[642]: *** Assertion failure in -[CheckPreflightOperation verifyDistributionAtURL:allowsDevSign:allowsUnsigned:osVersionToBeInstalled:error:distributionController:], /Library/Caches/com.apple.xbs/Sources/Commerce/Commerce-453/CommerceKit/CheckPreflightOperation.m:291

When I browse to /Library/Caches, I do not see com.apple.xbs.

As my first attempt to resolve this issue, I renamed /Caches to /Caches_old (paranoid, I guess, but the practice has stood me in good stead previously, so I think it's not the worst idea in the world), then closed and reopened App Store, and retried the installation.

I was now prompted to re-enter my iCloud password. I did so, and was presented with a new error message: “%Program% failed to download. Use the Purchased page to try again. In the Purchased page, the program had a line next to it, saying “An error has occurred”.

Once more consulting Console, I get this:

09/10/15 20:22:16,130 sandboxd[114]: ([314]) storeaccountd(314) deny mach-lookup com.apple.backupd.sandbox.xpc 09/10/15 20:22:17,347 storedownloadd[642]: SSDownloadAsset caching-server-locator-timeout 10

I tried renaming the old Caches-folder to Caches - no go.

I tried renaming the Caches-folder to Caches_Old, and then creating a new Caches-folder - no go.

I rebooted the computer - no go

I renamed the new Caches-folder to Caches_older, then renamed the Caches_old-folder to Caches, and rebooted - no go

Any ideas?

Update: I have also tried renaming the Caches-folder, and then rebooting. A new Caches folder is then generated, but the problem remains the same.

Update 2: I have tried starting the Mac in safe mode and trying it there. The error still persists, but now I get a new error:

12/10/15 21:12:20,744 sandboxd[128]: ([500]) ReceiptInstaller(500) deny mach-lookup com.apple.DiskArbitration.diskarbitrationd 12/10/15 21:12:24,747 storedownloadd[404]: AssetDownloadOperation no modified URL for http://osxapps.itunes.apple.com/apple-assets-us-std-000001/Purple/99/60/6a/mzm.zqwtwhxj.pkg

3

It might be tricky to pick apart the failure with caches being deleted.

One thing that always works for me is to boot to a USB drive with a clean OS and sign in to the App Store. If I get a failure there, I know the problem is on Apple's side or in the network.

If not, I have the app and know my system / library are not helping and can take action there once I'm sure the issue is with my customizations and specific install and not a server issue.

3

I have resolved the issue by retrying on (yet another) network. I had previously tried two networks, one of which was my home network, but it seems all of them had some sort of issue. On a different network today, it worked fine.

I think that the solution was to boot it in safe-mode, but I cannot be sure.

  • I see this same behavior, but the error message is completely instantaneous from clicking 'get' to getting an error. So, I'm skeptical that it's even trying to get to the internet in that time. Did you have to rename the caches folder before switching networks? – Tom Lianza Oct 25 '15 at 4:16
  • Good question. I'm not actually sure whether it was the network swap on its own, or if the caches-folder rename (effectively a delete) was also required. – razumny Nov 1 '15 at 11:18
  • I get this error resolved by switching to another network (VPN to a server located in anther country) – Shaun Xu Jan 28 at 4:19
2

This answer did not help me, and it took four apple support techs before I got one (iApps) who figured out the drop dead simple answer. This answer does not apply to the above problem, but it has the same error message, so I'm posting it here for the next person who has an equivalent problem.

This error message seems to be the last ditch answer from the App Store when it does not recognize something that is too new for it.

We could not complete your update. The product distribution file could not be verified. It may be damaged or was not signed.

For example, on Yosemite, I cannot open .pages files sent to me from users who are already on El Cap. When I try to upgrade Pages, as it suggests, I get this error. The only way around it is to upgrade to El Cap so I can upgrade Pages. Not ready to go there quite yet, so I'll just ask for the files in some other format for now.

enter image description here

  • I'm not convinced the app wasn't installing because your OS was outdated; rather, I think the error likely went away as a side effect of upgrading your OS. macOS isn't supposed to show incompatible updates... – Wowfunhappy Jan 26 at 4:25
1

Below works from me. Using Terminal run below command

open $TMPDIR../C/

Above command will open Finder window. In this window, find folder com.apple.appstore and delete it.

1

I had the same issue while trying to update an app from the Mac App Store. I fixed it by switching to another network.

I cannot download the app from my home network and encountered this error. Then I switched to my iPhone's 4G network using hotspot, and I downloaded the app successfully.

  • LOL, English is not my mother language. I had so many grammer and typo errors. Thanks for helping me to correct them. – Richard Jan 30 at 14:59
0

the solution is to agree to the new terms and condition all the way at the bottom if you press the update all tab....hope this helps

0

How do I accept the Terms and condition, I don't see that in the Mac App Store. I restored my old MacBook, and it goes all the way to 10.8.5 :-) and it was running Seirra before I restored. when I try to upgrade it to Maverick or El Capita or Yosemite or even Mojave, I keep getting the same error. It is very frustrating

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .