3

I ask Siri to "Send a text message to John Smith". I get a response, "You have two contacts named John Smith, and neither has a phone number or email address". However, if I bring up John Smith's contact information in Contacts, I see only a single card and that card has his emails and phone number.

If I ask Siri "Show me John Smith's contact information", I see John Smith's contact information. If I ask Siri "Where is John Smith?" Siri will show me where John Smith is in the Find my Friends App. If I ask Siri "Email John Smith", Siri replies "Which email address for John Smith" and shows me all of his email addresses. If I say "Call John Smith", Siri calls John Smith.

And, if I bring up the contact, and press the little speech bubble, I can text John Smith that way. And, I can also ask Siri to display John Smith's contact information and send him text that way too.

The issue only seems to be with text messages. John Smith also has an iPhone and uses iMessage.

Any idea how I can get Siri to find John Smith's email address or phone number when I text him? I have no problems with email or phoning John Smith through Siri -- just texting through Siri.

  • Were these imported contacts by chance? Pull Mr. Smith's contact page up, and see what the dropbox next to his set phone number says. If it's already set as Phone, try setting it as iPhone (or vice versa). Another thing to try would be to add an emoji or other unpronounceable character to the name of the "working" Smith, and then have Siri pull up the other one by name (and delete if necessary) – Mikey T.K. Oct 9 '15 at 21:17
  • Nope. Not imported although he has a Facebook profile in my Contacts. However, this doesn't affect others who are in a similar position. The thing is that Siri can find the contact information, email this person, and even call this person, so Siri knows the email and phone number. However, Siri can't seem to text. That's the only thing, and that's the most important thing. I can send texts to this person manually, but I want to be able to do this hands free like all my other contacts. – David W. Oct 9 '15 at 21:25
  • What phone number type is set for the contact. The default choices are "home", "work", "mobile", "main", "iPhone", etc. plus you can create your own entries. Another question: are you using regular iCloud contacts or another type like google or ms exchange? – Tyson Oct 10 '15 at 1:24
  • just for sake of completeness, have you tried 'send a text...', send a message...' & 'send an iMessage to ...' just in case Siri prefers one form over another. Also appending the contact type, 'iPhone' 'mobile' etc like you would for a phone call – Tetsujin Oct 10 '15 at 6:37
  • I have the phone number set as iPhone and I've tried all the various forms of text: Send an IM, send an iMessage, send a text, etc. I can send others text messages. I can do other things with this contact. I cannot send this contact text via Siri. Although I can reply via Siri if he sent me a text message. I changed his name, and I could send a text and it worked for a brief time when I reverted it back. Now it's broken again. – David W. Oct 11 '15 at 2:00
3

Okay. I fixed the problem — at least so far.

Deleting the entry did nothing. I recreated the entry, it initially worked, and then failed five minutes later with the same problem.

On my iPhone, entries are "unified". For example, my wife has an entry for someone, and I have an entry for someone, it shows up on my iPhone as a single entry. On my iPad, these show up as multiple entries. If Facebook creates an entry, a third one shows up.

I want to my iPad, and there were three entries for this name — two had email and phone numbers and one did not.

Deleting that mysterious third entry worked for about two minutes, but it reappeared a minute later, and I had the same issue again. I ended up editing that third entry and added a phone number and email addresses. That allowed me to text John Smith through Siri. It so far has held for two days. I can once again text John Smith through Siri. However, other people who have Facebook profiles and are in my phone book aren't an issue. It was just this one.


Addendum

The problem was tracked down to Facebook being allowed to munge my address book. This user didn't have phone or email information in Facebook, so Siri must have seen the Facebook info, and tried to use that. On my iPhone, the contact entries are unified, so I see both what Facebook puts in and my entry.

Turning off Settings->Facebook->Contacts solved the issue.

There maybe similar issues with other contact applications like Twitter and Outlook which might cause Siri not to see the information you have for a contact. Turning off these app's ability to update your contacts may solve the issue.

  • Bless you, sir. That Facebook thing was the answer for me, too! – JoshSamBob Sep 7 '16 at 17:28
1

Is the phone number you have for him labelled "Mobile" rather than "home" or work? That could possibly make a difference.

  • Welcome to Ask Different! This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Tetsujin Dec 13 '17 at 13:35
1

My wife was having this exact problem with a few of her contacts (but just the ones she wanted to send text messages to the most). I found that I was having the same problem with several of my contacts. We both got new iPhone 7 Plus phones recently. I was finally able to solve this problem by getting Apple to delete the cache of data from each of our phones that Apple stores on its servers to process Siri requests (which includes the contacts from the phones). To get Apple's servers to delete the cache for your phone, do the following:

  1. Open Settings, Siri, then turn Siri off.
  2. If you get a warning that this will remove your information from Apple's server (and it will take some time to rebuild it if you later decide to enable Siri again), then skip to step 5.
  3. If you get a note that says that Apple will keep your data on its servers to support dictation unless you also disable dictation, then you will need to disable dictation.
  4. To Disable dictation, go to Settings, General, Keyboard, then scroll to the bottom and toggle "Enable Dictation" off. Now you should see the warning about your data being deleted from Apple's servers.
  5. For good measure, turn your phone off (press and hold Power button until you get the "Slide to turn power off" message, then slide).
  6. Turn your phone back on.
  7. Go back to Settings, Siri, and turn Siri back on.
  8. If you turned off Dictation, turn it back on.
  9. Give your phone a few minutes to rebuild its cache of your data, then try Siri again. It should be working properly now.

This worked on both my phone and my wife's. I hope this is helpful to others that run into this problem.

0

I had the same problem where Siri would be able to pull up my wife's contact and even call her but not text her. Finally fixed that by going into Settings > iCloud and turning on Contacts.

0

I could solve it if I turned off my Outlook sync of contacts and just used a local copy. Then once I tuned the Outlook sync back on, Siri again said there were no numbers for that person.

I ended up creating a new contact with the first name and last name the same, with the same phone number as the original contact and that seems to have fixed it, but now I need to remember that if I'm texting my wife to use her first name twice!

0

I tried all the above. Failed. Then l went into my contacts, sent a message direct from the contact screen; then next time I asked Siri to send him a message voila!!! It worked!!! Finally

0

I deleted my contact completely and re added it and made sure the phone number was listed under "mobile" rather than home or work. Seems to have worked for me

-1

Tried unlinking ... didn't work.

Deleted old contact and created new one. Seems to have worked thus far

  • Welcome to Ask Different. This answer is not substantially different than the existing answers and it doesn't provide any new info. Please see How to Answer for info on how to provide answers. – fsb Dec 13 '17 at 16:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .