4

For years, I've successfully used Siri to create notes that were then synced with Gmail, as described here: http://lifehacker.com/5569758/seamlessly-sync-iphone-notes-to-a-gmail-account

A few weeks ago, this stopped working when the note is created using Siri.

This is how I get things out of my head into my GTD workflow, so it's a real problem!

Here's what I know:

If I create a new note by hand (go to Notes app, type in new note) it syncs immediately.

If I create a new note using Siri (for example, "Hey Siri, note, this is a test") the new note appears in the Notes app but not in Gmail.

enter image description here   enter image description here

enter image description here

If I subsequently manually edit that note in the Notes app (for example, add a space to the end of it) and save it, then it appears in Gmail.

enter image description here

enter image description here


Setup details:

I use the Gmail account for Mail, Contacts, Calendars, and Notes.

enter image description here

In Settings/Notes, I'm using Gmail as the "Default Account for Siri."

enter image description here

I've tried all the options for "New Notes Start With" (Title/Heading/Body); they all seem to work the same.

enter image description here

  • 1
    This is definitely a bug- I can file a radar if you would like me it. – Charles Truluck Oct 16 '15 at 23:29
  • I just upgraded to ios 9.2.1 and problem still exists, uggg! Has this been reported to apple as a bug? It really messed up my workflow of note taking and syncing to trello. – scottknight Jan 21 '16 at 15:05
  • I couldn't wait any longer for Apple to fix this so I found an alternative: ifttt.com/recipes/302806-siri-to-trello This syncs siri created reminders (not notes) to my trello board. IFTTT has gmail support so I'm sure you could have reminders sent to gmail notes though I haven't tried it. Hope this helps! – scottknight Feb 25 '16 at 17:27
1

I'm having the same problem on my iPhone 6 S. Like you, if I edit the Siri-created notes, they sync. In addition Siri won't create iCloud notes on that device (which is why I have reverted to Google notes.)

My work-around is to move all the notes to iCloud, which I then process on my Mac. That way, they keep the same time stamp, and I can do this in bulk on my iPhone 6 S (Notes.app) using Edit → Move All. Obviously not helpful if your other devices don't use iCloud.

my old iPhone 5, which I've kept, has none of these problems. Yet both my phones use the same OS (9.1). I'm considering keeping the old phone for Siri note-taking purposes until this gets sorted out, as I rely heavily on this feature.

I've logged a bug with Apple Bug Reporter.

You must log in to answer this question.

protected by Community Feb 14 '16 at 15:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .