8

I am trying to set up an LDAP account for the Contacts application in the 10.11 (El Capitan) OS X version. I need it, for example, to be able to autocomplete addresses via the Mail application.

I've been using this feature in older versions without problems, but with 10.11 I am unable to retrieve contacts from the server. Even on 10.11.3 - connecting to an OpenLDAP 2.4 server or to Active Directory 2008 R2 using a "formal" dn, login & password fails.

In this version the setup can be done vie the Internet Accounts at the System Preferences pane or directly in the Contacts app. The first nuisance is that the password can only be entered once the account has been enabled on the preferences on the Contacts app. Having found this, the new account only appears after restarting the app, and then, searching anything always returns an empty set.

The information to connect to the server (host, user dn, password, base...) is valid and works in previous releases. Doing an ldapsearch works fine as it does configuring the LDAP contacts in Thunderbird in OS X. It seems to me that it is related to the OS.

Is this a bug or is there a procedure to connect to LDAP?

  • What OS and version is your LDAP server? What OS and version is your user account client on? – bmike Oct 9 '15 at 15:48
  • I've tried it against an OpenLDAP 2.4 server, and also against Active Directory 2008 R2 using a "formal" dn, login & password... You name it. – Aleix Dorca Oct 9 '15 at 17:15
  • Still not working in version 10.11.3... – Aleix Dorca Jan 19 '16 at 18:54
  • I've bumped this with an edit, but you might need to contact Apple for guidance - their engineering team is very good about getting to the bottom of things like this, but you might have to use a Mac covered with AppleCare to get them on the hook for free support. A paid incident might run you $50 or so if you aren't covered by any support agreements yet. – bmike Jan 19 '16 at 19:49
  • 1
    I filed a bug with Apple. My bug was marked as a duplicate of bug 21707365. Today (2017-02-21) I was notified that the original bug was "recently closed." – Joe Pallas Feb 21 '17 at 22:33
2

I had checked network packets with wireshark and found that OSX 10.11 and 10.11.1 do not send bindRequest to LDAP server (only searchRequest and unbindRequest), nevertheless authenticate method was configured as 'simple authentication'. This is bug.

  • Interesting. I'm having the same problem: what worked before suddenly no longer works. I don't need a login and password. I'm also finding that when I try to set the port # to 389, it always reverts to "Auto" What's weird is that a user at my university claims that LDAP lookups work for him in 10.11.1. – odysseus Nov 24 '15 at 14:49
1

same here. and I checked the ldap server, the log shows it never be connected. it may be the 10.11 problem

  • 1
    I see this as +1 and saying its a bug. This answer could be wrong, but it clearly is an answer. – bmike Oct 9 '15 at 15:47

You must log in to answer this question.

protected by Community Nov 14 '15 at 23:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .