2

Just upgraded to El Capitan on my Mac mini. Mail has a problem though I have multiple mail accounts set-up

  1. The outgoing SMTP smtp server for all accounts is NONE
  2. If I assign one from the drop list it tries to apply that selection to ALL accounts
  3. The "Edit SMTP server list" option in the drop down box is now missing

I've deleted all the accounts (closed mail, restarted, re-opened mail) and added back 2 of them but all these issues still exist.

Can't see anyone that has my issue although a lot seem to have the outgoing mail server issues.

My Macbook Pro (older) upgrade did not have these problems (although a small issue with one account easily fixed) the "edit SMTP server List" options appears as it always did and different outgoing servers can be assigned to different mail accounts.

Not sure what else to do??????

  • I actually figured a way to fix this. I set the outgoing server to NONE (changing 1 changes the whole lot.....thats part of the problem) and then sent an email message. – Mike W Oct 13 '15 at 3:42
1

It seems that the solution is to delete all accounts (hoping you have no pop accounts) and recreate them, but not in Mail; go to System Preferences>Internet Acccounts to delete and recreate the accounts. When you recreate one, you have the choice to choose email account only (scroll down to Add another count (not sure of the english, I translate from french) and clic on it. Of course, work with Mail closed. The account you create there are created in Mail.When you finish to recreate all your accounts, reopen mail, et voilà!

0

Is the issue happening if you make a new user account and enter the Mail account.

If so, it's actually an El Capitan bug (or problem with your mail server working with El Capitan).

If not, then it's just a corrupt preference file.

0

Uncheck mail from the account choices, close that panel and return to re-check mail in each account.

I had my Mail app set to all accounts offline and quit first to be sure. After I did the above I launched mail and reset accounts back online. Success!

0

Close Mail. Uncheck "mail" in your Internet Accounts. Then close the Internet Accounts pane. Open Mail and look at the SMTP settings of the offline account. You already see when you pick an Outgoing Mail Server, your choice is kept and doesn't jump back to 'none'. Now in Internet Accounts, check "mail" again. Now send a test message and see if it works, if not choose the default, e.g. Gmail.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .