My 1TB LaCie Rugged THB decided it was a good idea to stop working all of a sudden. If I open it in disk util I sometimes see an actual name of a partition, but most likely it's not the real name.

In Terminal I tried:

diskutil list
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            140.0 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
   4:       Microsoft Basic Data BOOTCAMP                110.1 GB   disk0s4
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *1.0 TB     disk1
   1:                  Apple_HFS                         150.1 GB   disk1s1
   2:                 DOS_FAT_32 BAK_WIN                 150.0 GB   disk1s2
   3:                  Apple_HFS                         100.0 GB   disk1s3
   4:                 DOS_FAT_32                         120.0 GB   disk1s5
   5:                 DOS_FAT_32                         480.1 GB   disk1s6

And then to unmount this:

$sudo diskutil unmountDisk force disk1

gave this: Forced unmount of disk1 failed: at least one volume could not be unmounted Than for each disk:

$sudo diskutil unmount force disk1sn

Always: disk1sn was already unmounted

Because I wasn't able to do anything with my external HDD I made a desperate attempt to erase everything on it, including unbackuped files, cause this used to be the backup plan. This was the try:

$ sudo diskutil eraseDisk JHFS+ DISK_VOLUME disk1
Started erase on disk1
Unmounting disk
Error: -69888: Couldn't unmount disk

But it didn't work as well. If you have any idea to get the HDD working or even safe the files, I would be really grateful.

Almost forgot about this from Disk Utility:
Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.

  • Just to be clear - you don't need any files from this drive, just that you want it to get erased and put back into service?
    – bmike
    Commented Oct 8, 2015 at 21:24
  • I'd like to have the files, but if there is no other way, I'd be grateful to be even able to use it again. But would mean the loss of many fotos :-/
    – Peter
    Commented Oct 8, 2015 at 21:28
  • This answer helped me! raspberrypi.stackexchange.com/questions/9217/…
    – Aaron
    Commented Jul 5, 2023 at 6:37

6 Answers 6


For me, none of the solutions were working: sudo unmount, sudo unmountDisk, unmountDisk force, etc., with /dev/disk4, /dev/disk4s1, /dev/disk4s2, and so on. All failed. The last thing I tried - eraseDisk - gave me the same error: Error: -69888: Couldn't unmount disk

Then I decided to see if there were any processes in my way, so I ran sudo lsof|grep disk4 and found a process working on one of my partitions. I killed the process id and suddenly the disk mounted again! Success!

  • Well the disk hasn't worked until today. But I kept it, lets see what I can do :)
    – Peter
    Commented Dec 9, 2015 at 7:37
  • Good luck, hope it works!
    – Dannid
    Commented Dec 9, 2015 at 8:00
  • Although I believe in your answear (also found it in other blogs) my system won't recognize the drive anymore. But thank you anyway :)
    – Peter
    Commented Dec 10, 2015 at 6:48
  • @PeterSchmucki can you see the disk at all when you run diskutil? (I have more experience fixing bad drives on windows, so that would be my next solution: find a windows machine and delve into it there.)
    – Dannid
    Commented Dec 11, 2015 at 0:03
  • Wasn't able to see it diskutil last time, however I sometimes see the drive on Windows 7. I have my main disk partitioned, I could boot from Windows. My VM of Linux on the other hand never saw the disk, probably a configurtation issue, don't really sure about it though
    – Peter
    Commented Dec 11, 2015 at 6:54

The same thing happened to me because I was in the same directory as the USB drive.

I went back into my home directory (cd ~) and ran the command again and it worked.

  • this worked because I was trying to unmount the disk while I was in the disk (dooh). I just used cd .. to go up a level which moved me outside of the disk I was trying to unmount. Commented Nov 25, 2016 at 3:42
  • +1 Unbelievable, I've tried so much until cd ~ solved the problem. Thank you very much! Commented Dec 16, 2018 at 11:06

I found I got this problem when I was using iTerm instead of terminal, if the other fixes don't help try changing to terminal if you're using something else


I confirm that using Terminal instead of iTerm2 surprisingly made the command diskutil unmount and diskutil mount work!

  • Strange this just worked for me too, never would have thought to try it.
    – Hiro2k
    Commented Nov 4, 2019 at 17:50
  • add iTerm to SIP if this happens
    – novski
    Commented Nov 29, 2019 at 5:23

All of these methods above used to work on my machine. It seems that after a while it won't work anymore. For some reason, this problem begins to happen whenever the drive is removed unsafely. For instance, my macbook doesn't have a battery, so, if the electricity of my house fails or if the power cord is unplugged, when I reboot my computer, the drive won't work.

The only way I found to work every time is to launch a virtual machine, with a Linux distro or Windows, on the same computer isn't mounting and force the drive to mount on it. [1] You can click on devices, usb 2.0 (or 3.0) and look for the device. As soon as it mounts, you remove it safely, shutdown the virtual machine, or uncheck the device, reversing the step [1].

If it doesn't automatically shows up on your Mac, you can unplug it and plug it again.

Ps.: This method was done using a Virtual Box VM, but it'll probably work using Parallels, VMWare or even a Live CD (usb) Linux Distro.


As suggested by the Apple help info, when erroring during the eject, logging out from the session (Apple logo > Logout) and coming back was enough to eject it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .