Yesterday, I decided to restore my iphone to factory default setting . So I format my iphone through setting menu (but the battery was low) . Then i kept my phone on charge but nothing happen. I also bought a new charger and cable but my iphone won't charge. I have been trying to reset it (holding power and home button) and I have tried putting it in safe mode but no luck .

Nothing is happening , even after charging for 2-3 hours . No logos , no indications , no buttons etc.

  • when you plug your iPhone do you see the charging screen ? when it's not charging and you push the power button do you see anything on the screen? – enzo Oct 8 '15 at 16:22
  • Nope everything is black. when I plug my iphone it shows nothing . I also tried pushing power button ..nothing works . – akshan Oct 8 '15 at 16:29
  • If you have a mac connect your iPhone through usb and run system_profiler SPUSBDataType | grep iPhone or just system_profiler SPUSBDataType and check if there is some information about your iPhone, if nothing is showing then maybe the battery is dead, try replacing it this all I can think about. – enzo Oct 8 '15 at 16:39
  • Google DFU mode and follow the instructions, you will need iTunes. – Tyson Oct 8 '15 at 16:42
  • I don't have mac. – akshan Oct 8 '15 at 16:52

is your pc/laptop recognize the iphone (after connect to pc)?. try connect usb cable with pressed home key.

  • not recognised. – akshan Oct 8 '15 at 16:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .