3

Okay so here's my problem. I want to change the icons of the Dashboard, Launcher, Quicktime, Notes, Mail etc. But when I paste my icon to the top left mini icon in the preview window (on the Get Info page) it won't let me. Then I tried to change the permission settings to be able to edit the icon or change anything in the application folder but it tells me that i do not have the permission even tho I'm the sole user of the Mac.

I'm on El Capitan so I don't know if it's because of the new upgrade.

I was trying to change the privilege of "everyone" to read & Write

  • Apple Apps have special permissions to prevent you from easily deleting them which also prevents you from changing the icon. This has been the case for several previous versions, (if not all versions,) of Mac OS X. When you try to chuck an Apple app in the Trash, you get the message “<app_name>.app” can’t be modified or deleted because it’s required by OS X. May I ask why you want to change the icons on all these apps? – IconDaemon Oct 8 '15 at 11:48
  • 2
    @Syma, Have you tried temporarily disabling SIP, change the icons and reenable SIP. System Integrity Protection is new in OS X El Capitan. – user3439894 Oct 8 '15 at 12:14
3
  1. Turn off your Mac.
  2. Boot it in Recovery Mode by holding down ⌘-R until the Apple logo with a progress bar pops up.
  3. Click "Utilities" in the menu bar, and select Terminal.
  4. Type the command "csrutil status" and press Enter.
  5. If enabled, type "csrutil disable".
  6. Press Enter.
  7. Click the  in the menu bar and select Restart.
  8. Now, the copy and paste method should work.

For more detailed instructions, check out http://hashbangstar.net/blog/changing-icons-in-el-capitan

You can also download a program called Liteicon from http://www.macupdate.com/app/mac/24764/liteicon

You still have to do steps 1-8 but it makes changing icons super easy! You can also easily change the Finder icon and Trash Can by using the drag and drop method.my current desktop with custom icons

  • 1
    Nice color scheme and background image! +1 – bmike Oct 9 '15 at 1:11
0

I don't know if you were having the same problem I just was facing, but here's what was happening to me and how I fixed it.

I had an app I'd created using Fluid.app. I had selected an image in Fluid to use as the app icon, but it didn't work. I ended up with the generic app icon. So I went to "get Info" on the app and when I clicked the icon at the top and tried to paste the copied image, the size of the app changed (i.e. megabytes on disk), but the icon still did not appear.

To fix this, I right-clicked the app and selected "Show Package Contents". I went into the subfolder Contents->Resources. There was no appl.icns file there, so I converted my image to icns format using the image2icon app (free from the mac app store). I then named the file "appl.icns" and dragged it into the resources folder. This did not change the appearance of the app's icon immediately. I had to then go into "Get Info" again and paste literally any image and it then updated to the image I'd saved as appl.icns in <*.app>/Contents/Resources.

Note, I had tried pasting images into the get info window of type png, tiff, pict, icns, and various correctly sized versions of these formats. Nothing was working. I think that at some point, my computer had run out of application memory which might be how I got into this situation because I had previously created another fluid app which I had been able to paste an icon onto in the usual way. I'm due for a restart, which should ultimately fix my issue, but I've got too many open projects at the moment.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .