2

I have a Creative Labs webcam (VF0700) that was working fine on Yosemite, but since the upgrade to OS X 10.11, it has stopped working. It is recognised under the System Report in 'About this mac' and if I shut the mac down, plug it into the USB port before rebooting, it works fine ... until I unplug it and then it doesn't work again.

I have asked Creative support, and they say 'it's not supported' but the fact that it works with a reboot gives me some hope that there may be a workaround and I don't want to have to buy a new webcam for the odd few times that the iSight camera is not suitable.

Is there a command I can use to force the USB port to restart (as if I rebooted the Mac) or some other method I can use to get the webcam working without needing to do a complete reboot each time?

  • For the builtin camera, sudo killall VDCAssistant worked for me (found on apple dev forums). Not sure if that works for external cameras too. – Kevin Oct 27 '15 at 4:28
  • Thanks for the suggestion. I have tried each combination I can think of (execute the command with camera plugged in, unplugged etc) and its still not recognised. – BudgieUK Oct 29 '15 at 8:34
  • I have the same camera and the same problem on High Sierra - any update on what you did here? Time to buy a new camera? – brainwood Mar 15 '18 at 22:52
2
  • Open activity monitor
  • Search for usbmuxd
  • Click on terminate process
  • Enter Admin password if required
  • Reinsert your usb device

This worked for me a while back when my usb modem wasn't working on Yosemite.

  • Thanks for the suggestion... I have tried it this morning but unfortunately it hasn't worked for me. I can see the process end, and restart, but it still does not detect the webcam. Thanks anyway :) – BudgieUK Oct 9 '15 at 9:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .