9

I've got the following setup: A 2010 MBA and a 2013 rMBP, both running El Capitan (same issues on Yosemite though), connected to an AirPort Express 802.11n (1st Generation), which is connected via an ethernet cable to a Cisco router/modem. Airport is running in bridge mode.

10-20 times a day, internet connectivity will drop for between 10 and 90 seconds. iPads and iPhones never have issues, only the macs. The wifi connection is fine, it's just internet. Generally, only one mac loses internet connectivity, the other mac remains connected.

I'm pinging an external server, the modem and the airport continuously. During downtime, the external server is unreachable, but both the airport and the modem remain reachable.

What immediately restores the connection is clicking "Renew DHCP Lease" in the Network Preferences.

I tried to programmatically renew the DHCP lease as soon as downtime was detected (sudo ipconfig set en1 DHCP), but that seemed to confuse the wifi connection status in the menu bar.

I'd like to solicit tips to pin down the problem in more detail, or to solve the problem entirely. (Cutting out the Airport and using the cisco router/modem directly produced similar problems).

UPDATE:

My connection goes down every 15 minutes, like clockwork. When it's down, the DHCP entry for my laptop disappears from the list of DHCP entries in the web interface of the Cisco, even though it was not about to expire.

  • same problem here 13" mac pro 2014, every ten minutes its down for 30 seconds or so - i'have set a ping every 5 sec's in terminal so quite clear to see. Same mac's with os 10.10 doesn't have the problem. – user153179 Oct 19 '15 at 14:56
  • Same issue on a fresh Macbook Pro (mid 2015) running El Capitan. – mitchus Oct 23 '15 at 13:44
  • I put my cisco router in bridge mode, put a fancy router in front of it, and now the problem is gone. Mystery remains unsolved however. – Michiel de Mare Nov 4 '15 at 8:53
  • Encountered the same. I've tried a CMD+OPT+P+R with no change. I've also set IPv6 to Local-Link-Only with no change. Periodically forces a reboot. – Mark Nov 29 '15 at 14:47
  • Same here, and the renewal of the DHCP lease fixes the problem right away. A reboot also, for a few days, but then the problem comes back. – Guy Moreillon Jan 6 '16 at 21:08
2

I run into the same issue with El Capitan on a mid-2014 MBP 13". Did run a wireless diagnostic and captured the drop, the RSSI value seems to change the most but I don't know what that could mean or if it's actually part of the problem.

Turning wifi off and back on fixes it.

10/08/15 12:34:31.0430  Link Quality Changed : rssi=-59 dBm, txRate=117 Mbps
10/08/15 12:34:44.0550  Link Quality Changed : rssi=-62 dBm, txRate=104 Mbps
10/08/15 12:34:45.1200  LAN: WiFi interface can ping IPv4 router 192.168.0.1 . . . YES —— [1/1 (0% loss) min=2.1 max=2.1 avg=2.1]
10/08/15 12:34:54.4610  WAN: WiFi interface can ping DNS server 17.254.0.50 . . . YES —— [1/1 (0% loss) min=24.5 max=24.5 avg=24.5]
10/08/15 12:34:54.4610  moto / ch1 [RSSI=-62 dBm, Noise=-95 dBm, SNR=33, Tx=78 Mbps]
10/08/15 12:34:54.4610  AWDL: Disabled [0 ]
10/08/15 12:34:55.0640  Link Quality Changed : rssi=-62 dBm, txRate=52 Mbps
10/08/15 12:35:08.0790  Link Quality Changed : rssi=-61 dBm, txRate=78 Mbps
10/08/15 12:35:09.5260  LAN: WiFi interface can ping IPv4 router 192.168.0.1 . . . YES —— [1/1 (0% loss) min=4.1 max=4.1 avg=4.1]
10/08/15 12:35:17.6310  WAN: WiFi interface can ping DNS server 17.254.0.50 . . . NO —— [0/1 (1% loss) min=0.0 max=0.0 avg=0.0]
10/08/15 12:35:17.6320  moto / ch1 [RSSI=-58 dBm, Noise=-94 dBm, SNR=36, Tx=78 Mbps]
10/08/15 12:35:17.6320  AWDL: Disabled [0 ]
10/08/15 12:35:17.6320  UNEXPECTED DROP DETECTED!!!
0

On upgrading to El Capitan I had a similar problem, but with an ethernet connection. In fact I couldn't connect at all - I could ping the DNS server, but nothing beyond.

Anyhow, I did a clean install of El Capitan (after backing everything up!) and the problem has disappeared. So perhaps that would be a possible remedy. (One of our network gurus suggested that it might have been trying to use IPv6, which the DNS servers wouldn't handle properly.)

  • About IPv6: I suspected something like this and disabled IPv6, but it did not help. – mitchus Oct 23 '15 at 13:46
0

Please try reset NVRAM on your Mac:

  1. Shut down your Mac.
  2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R.
  3. Turn on your Mac.
  4. Press and hold the Command-Option-P-R keys immediately after you hear the startup sound.
  5. Hold these keys until the computer restarts and you hear the startup sound for a second time.
  6. Release the keys.

You must log in to answer this question.

protected by Community Nov 24 '15 at 18:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .