6

We've upgraded some MacBooks to El Capitan, all the workstations here are connected to a NAS through AFP. All upgraded workstations now show a small amount of folders with strange names like;

  • SBAK7C~3
  • GE3HHX~F
  • DWBENE~Y

These folders are still accessible for El Capitan. The non-El Capitan (Yosemite) workstations show the normal names.

What could be wrong?

6

Are you sure that all workstations are connected via AFP?

I bet you get the strange folder names because of mangled names = yes (the default) in the samba server configuration. Check Synology bad filenames or Samba name mangling for more information. One solution is to disable SMB on the NAS another is to force OS X to connect via AFP e.g. afp://user@servername/folder via "Finder->Go->Connect to Server".

Of course you can set mangled names = no in the Samba configuration but this creates problems when you connect via SMB to the server.

Samba (SMB) creates the strange names when the file or pathname contains the characters / ? < > \ : * | ", with AFP it's not a problem to read or write file or pathnames with these characters but not with SMB (Samba).

Since Mavericks (10.9) Apple prefers the SMB protocol over the AFP protocol, check Mavericks Core Technology Overview PDF for more information. For Mavericks (10.9) it is SMB2, for Yosemite (10.10) and El Capitan (10.11) it is SMB3.

From the PDF-Dokument:

SMB2 is the new default protocol for sharing files in OS X Mavericks. SMB2 is superfast, increases security, and improves Windows compatibility.

So the future is SMB3 not AFP but the problem is that you have already files with the characters / ? < > \ : * | " somewhere on the NAS because with AFP it was not a problem to create such files but when you read these files via SMB you get the mangled names, so first you have to fix the filenames via AFP or go directly on the NAS (via ssh) and fix the filenames there.

Better is a newer version of the Samba-Server >= 4.2 (maybe with DSM 6.0 from Synology?) with the module vfs_fruit which adds Apples SMB2+ extension to Samba. SMB on the Synology NAS is slow for Macs because of the missing module vfs_fruit (and because the Samba-Server has the version 4.1). So if you use only Macs, turn off SMB on the Synology NAS and use AFP only (for the moment) but if you need SMB on the Synology NAS, well... fix the filenames, turn off AFP and try SMB but... test if the speed of the SMB share is good enough for you.

  • Thanks for your reply @GM.! Apparently, El Capitan resets the protocol to SMB, normally it just connected through AFP. After your post I double-checked the protocol and noticed it being loaded through SMB! Unmounted the NAS and reconnected through Go -> Connect to server... and used the AFP protocol fixed the issue! Thanks a lot! – Ambidex Oct 13 '15 at 9:44
  • 1
    I added some information about SMB and that Apple prefers since Mavericks (10.9) SMB over AFP. – GM. Oct 13 '15 at 14:17
  • Great answer GM. Thanks. If I understand correctly, I'd be better of switching all our colleagues to SMB? When people are still connected through AFP, they are able to create those mangled names? If there is no one on AFP there is nobody that could create those mangled names? – Ambidex Oct 13 '15 at 16:34
  • 1
    I added some information why it is in the moment maybe a problem for Macs to use SMB on a Synology NAS. The problem is well... complicated :-). I have the same problem (Synology NAS, Mac and Windows Systems) and right now I'm not happy with SMB on the Mac, I hope that Synology updates the Samba-Server with DSM 6.0... but who knows... – GM. Oct 13 '15 at 19:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .