I've been working on macs for a couple of years now, and recently switched jobs (Software dev). Before when I was typing something like "e would not automatically merge into ë. This is really annoying in terminal And I don't know how to disable this as of now (I googled but not sure what I should be looking for). One of the most annoying things I encountered was when I need to go to my home dir in terminal (using tilde) when tying by default it will complete to ˜/ whilst I would like to see it act like before: ~/ which requires me to type an extra space.

I never need the auto completion for accents since I'll use the menu which opens when you hold the key instead.

Does anyone know what could cause and get rid of this behaviour.

My keyboard settings are US-Internation (which is normal in the Netherlands) and my MacBook is fully updated to El-Capitan.

up vote 4 down vote accepted

I had same problem, just change U.S. International - PC input source for U.S.

enter image description here

  • I'll try that but I believe my numpad's dot was set to comma at that point don't have a keyboard with me as I'm working form home today but I'll check that out on monday. I guess I'll go for that option over dot on numpad :'( – Mathijs Segers Oct 9 '15 at 7:12
  • Don't know what I did before but it's just fine the dots are still dots. – Mathijs Segers Oct 12 '15 at 11:04

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.