How do I delete default route of "link#8" gateway on OS X El Capitan? It's a route automaticaly added after connecting to IPSec VPN.

$ netstat -rn
Routing tables

Destination        Gateway            Flags        Refs      Use   Netif Expire
default            link#8             UCS            21        0   utun0
default          UGScI          16        0     en1          UH              0       11   utun0         link#8             UHWIi           1       27   utun0

$ ifconfig 
    ether 60:33:4b:04:d4:7a 
    inet netmask 0xffffff00 broadcast
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active
utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1280
    inet --> netmask 0xffffff00 
    nd6 options=1<PERFORMNUD>

This doesn't work:

$ sudo route -n delete default -ifscope utun0
route: writing to routing socket: not in table
delete net default: not in table

$ sudo route -n delete default "link#8"
route: bad address: link#8

1 Answer 1


This worked:

sudo route -n delete default -link 8
  • Thank you! Be careful though - if you are not connected to the VPN this will delete your normal default route (seen on Mojave)
    – mvreijn
    Mar 18, 2019 at 8:20
  • 6
    Cisco VPN adds again the link once I delete it. Does anybody solved this?
    – jotacor
    May 31, 2019 at 8:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .