2

I tried to install MuPDF on OS X 10.11 using Homebrew:

brew install mupdf-tools

But when I try to use it from the command line (it doesn't show up on Launchpad) I get the following error:

mupdf example.pdf
-bash: mupdf: command not found

Looking around a bit, I find 64-bit executables for mudraw, mujstest and mutool in /usr/local/bin. These commands seem to work. But there is no executable for mupdf there or anywhere else that I can find (using the find command). Any ideas what has gone wrong?

  • mupdf-tools runs as mutool – Salal Aslam Feb 25 '17 at 2:45
2

Run mupdf-x11

This works both for mupdf-tools and mupdf from homebrew since they install the same binaries

  • Thanks, MalCos. What I did in the end was 'brew install mupdf' and then, at the command line, 'mupdf-x11 example.pdf'. That worked. – lovecraftian Oct 25 '15 at 17:10
3

MalCos answer is correct. Just one addition:
MuPDF is a command line program and does not offer a graphical frontend to load files. I was missing this functionality and scripted MuPDF Droplet for it.

MuPDF Droplet is a GUI for MuPDF under OS X to drop your PDF/whateverMuPDFsupports-Files on to the program icon and they open with MuPDF. So you don't need to know the CLI command to start MuPDF...

MuPDF Droplet was created using Platypus, the source is included in the distribution DMG. Download MuPDF Droplet, it's Open Source licensed under GPL.

  • Recent versions of MuPDF do have a GUI now. – Adrian Zaugg Mar 8 at 8:56
2

As of 2019, the accepted answer doesn't work for me.

I installed it with brew install mupdf

After that, mupdf-gl, or mupdf-gl <file path> works. You might want to redirect STDOUT if you are using it in a script, for say in midnight commander like this:

# PDF
type/^PDF
    Open=mupdf-gl %f >/dev/null 2>&1 &
  • Excellent answer! I created a mupdf function in my bashrc: mupdf () { mupdf-gl $1 >/dev/null 2>&1 & } – Adam Erickson Feb 23 at 7:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .