3

So I recently updated my OS X to El Capitan and after it had been installed, I booted Parallels Desktop 9 to find that it would no longer connect to the internet.

On boot up, it says:

Failed to open the Parallels networking module.

and then suggests:

Your virtual machine will continue to work normally, but the networking will be disabled. You can fix the problem by restoring the default network settings. To this effect, go to Parallels Desktop > Preferences > Network and click Restore Defaults.

However, when I go to Restore Defaults, it says that it has failed and that it was not reverted to the default settings. I have searched up on the Parallels support forums and it suggests to Repair Disk Permissions but I have tried that and nothing has happened! Please help!

  • You are not alone: forum.parallels.com/threads/…. Had tried some older KB for Mac OS fixed but no luck. Guess it is new OS that causing the network module for parallel. – user151176 Oct 8 '15 at 1:47
  • This sounds suspiciously like Parallels' networking wasn't ready for El Capitan, or that the networking module they use was damaged/disabled by the upgrade. Have you tried just straight-up reinstalling Parallels? You also may want to double check that Version 9 is compatible with El Capitan. – Mikey T.K. Oct 8 '15 at 2:45
  • Ahh thanks for the suggestion but I cannot reinstall it as my brother set everything up for me :( I think the only way around it would be to purchase the latest version of Parallels! Thanks anyway @Mikey – Lily Oct 9 '15 at 20:37
2

Unfortunately Parallels Desktop 9 doesn't officially support El Capitan. I've received two Service Notification emails from Parallels which state:

If you intend to upgrade to Mac OS X El Capitan (10.11), please note that Parallels Desktop 9 for Mac will NOT support OS X El Capitan (10.11).

Before you upgrade to OS X El Capitan, be sure to upgrade to Parallels Desktop 11 for Mac. It is our latest version, fully optimized and enhanced for OS X El Capitan.

(From past experience, I usually have to upgrade Parallels Desktop every second OS X release. I'm currently on Parallels 9, am thinking of upgrading to El Capitan and came across this question when trying to research if I really do need to pay to upgrade Parallels. Unfortunately it appears I do...)

0

I have the same problem. I tried to reinstall it several times and doesn't works.

Looks like you need update to last parallels version. Actually I have Parallels 8 and I must buy a full version because the upgrade is only from 9.0

I changed to VirtualBox that's free and works fine.

-1

This problem with Parallels networking module after upgrade seems to be repeated from version to version. Looks like that this is just a way to encourage existing clients to buy a new version of Parallels. Switching to VirtualBox must be real solution.

  • Welcome to Ask Different. Please refrain from adding comments in the Answer section. This is for answers to the questions only. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. See How to Ask for more info on how to ask a question. - From Review – fsb Oct 27 '17 at 14:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .