12

It happens with unusual frequency that a notification will pop up covering the top right area of my window, right when I need to get a something in that top right area. I'd rather not have to wait the 5 seconds for the notification to go away. Is there a way to dismiss the notification right away?

I had read here that a right swipe on the magic mouse would do the trick, but that doesn't seem to be the case, at least for me.

1
  • This question about dismissing notifications with a keyboard shortcut might be of interest to people who end up on this page. – mattliu Nov 30 '16 at 4:31
10

With a trackpad or mouse, you can click the notification and drag it right towards the edge of the screen. If you do it fast enough it's almost like a swipe.

On a trackpad you can also just swipe right with two fingers.

2
  • 5
    My two-finger swipe gesture has stopped working for some reason on a fresh install of Sierra. Any idea where the setting is to turn this on? – Matthew Jan 16 '17 at 9:30
  • For me the three fingers swipe works instead of two, using touchpad, on 10.13 – ryenus Jul 27 '18 at 3:24
11

in el Capitan, the swipe away feature was disabled for Reminder alerts. Now you have to click Later.. then click 1 hour, 1 day, etc.. So they changed a simple swipe away gesture with 2 clicks.. per notification. It makes it way more complicated, I don't know what Apple was thinking when they changed this, at least they should give the option of making it simpler.

1

If you go to settings, I think you can change the setting from alerts, to banners, which can be swiped away, unfortunately now they disappear after few seconds, but they will still be in notifications centre by swiping in with two fingers from the right of the track pad.

NB I am running OS sierra.

0

In my case the problem was hidden in settings. Swipe to scroll between pages have been seated up for 3 finger gestures and dismissing a notification did not work. After setting back to "two fingers swipe" it is working again. Looks like apple bug for me, but solved - at least for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .