8

I am one of the many who have extremely blurry fonts on external displays connected to my 2014 MacBook Pro. The solution for me has always been to follow this guide which runs a ruby script and puts the result in an overrides folder.

EDIT: By turning off the new "rootless" feature of El Capitan I was able to gain access to the overrides folder, however it does not appear to have worked. Anyone had any luck fixing the blurry fonts on external displays for El Capitan?

4

The location of the Overrides directory changed to /System/Library/Displays/Contents/Resources/Overrides/. Note that you will need to disable System Integrity Protection to add files there.

  • Thank you! I can confirm for those that find this that the old Overrides folder does not work, however, going through the normal process and moving the created folder to the one above does indeed work. – KJ3 Oct 18 '15 at 23:57
  • No need to disable SIP, just do it in Recovery mode. See: ireckon.net/2013/03/… – Frederik A. Winkelsdorf Feb 28 '16 at 13:44
2

It is a good idea to check whether the monitor in question is already using RGB before the above is attempted as it may not achieve any benefit. To check: Utilities/System Information->Displays and look to see if it is using RGB (You can also check in System Preferences->Displays-> Color->Open Profile->Header->Space) if so then your problem lies elsewhere.

Another possible solution is to try altering Font smoothing options in System Preferences->General'. Or if you're seeing problems in a particular app - e.g. In Preview go to Preferences->PDF and untick 'Smooth text and line art'.

0

To my experience it was caused by the HDMI connection. I replaced it with a DisplayPort adapter and the problem is solved.

The display auto settings must be different when it detects HDMI and can't find the right parameters for some reason.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .