4

Whenever I sync any song to my iPhone, some of the songs / albums display the wrong album art despite having the correct album-art in iTunes. I have had this issue since iOS 8 and all of my devices are up to date on the software side. Check out the examples below:

Incorrect Album-Art Incorrect Album-Art even after re-sync

For example, Ride of the Valkyries shows album-art of ‘A Sky Full of Stars’ when I first synced to the device. After I deleted it from my iPhone and synced the song again, it showed album-art from ‘Songs from The Martian’. For the record, these albums are present in my iTunes library and they display it correctly. Be advised, this problem only with the album-art, not the song meta-data.

Hardware Info: iTunes 12.3 on Windows with iPhone 5 on iOS 9.0.2

1

After digging a lot of sites on the web, also including StackExchange, I finally stumbled on this blog by Kirk McElhearn. However, it only pointed me the right direction. After trying different methods, the correct solution was not to disconnect my iPhone from the internet while I synced, but to disconnect my PC from the internet before I started the sync process. Here is the result:

Correct Album-Art by applying the solution

And voila!

It finally showed the correct album-art. However my problem was fixed only for that particular song. I had to delete all the songs that had mismatched album-art and re-sync those songs again. It was a pain-in-the-a**, but the result was worth it (if you are particularly OCD about keeping your music perfect).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .