Since installing Lion on my Late 2007 MacBook Pro, which cannot support AirDrop, an icon called "Network" has appeared under Favorites in my Finder sidebar. This icon seems to have no function. Clicking on it only reveals the error message

"Network" can't be opened because the original item can't be found.

There is also no option to disable its appearance in Finder Preferences.

The Network icon seems to disappear on occasion, only to reappear later.

I can find no documentation of this mysterious icon, and no reference to its existence anywhere.

Can anyone suggest what this icon is and why it is being displayed?

enter image description here

Addendum: Note that there are indeed other network computers visible on my LAN in the finder, whereas the little gray Network icon in the Sidebar does not display any of them.

enter image description here

Note that there is no item named "Network" for me to remove in my Finder preferences:

enter image description here

  • 1
    When I opened Finder's preferences under Sidebars there was no option to show link called network; all my networked devices & computers are under shared Commented Aug 9, 2011 at 5:10
  • Did you used SIMBL for colorize the sidebar? I'm the same problem, Basically that Icon (seems to be 3 computer: mini iMac and a portable) should appear under "SHARED"/All... as it is on another Mac I have. This network item should not exist.
    – user25204
    Commented Jul 12, 2012 at 21:36

5 Answers 5



In Terminal, run the following command. You should find the word Network mentioned at least once in your .plist preference file:

defaults read com.apple.sidebarlists | grep Network


As I can't drag Network to my Finder sidebar — and as sidebar takes a different approach to showing shared items — I guess that:

  • in Lion, Network is no longer applicable in the FAVORITES part of the sidebar
  • maybe for you, Network was amongst sidebar favourites in a previous version of the operating system.

Removing unwanted items from the property list

Probably easiest with Xcode.

If you don't have Xcode, then use TextWrangler or anything that's capable of editing this type of property list.

Identifying items in the .plist

Xcode views of the property list:

Xcode view of the property list with all items collapsed Xcode view of the property list with three of five word matches visible

A TextWrangler view:

TextWrangler view of the properly list with all word matches visible

To view Network, with or without the sidebar


In the sidebar

  1. show SHARED
  2. click All…

screenshot of Finder, 'All…' presenting Network

If the option 'All…' does not appear

First try removing, from the property list, unwanted or redundant items relating to Network.

A guess: it may be necessary to quit Finder, or log out, before some types of change become effective.

If following removals and a log out you find that SHARED is still without All…, consider asking a separate question.

  • Thanks for this incredibly detailed reply. However, I followed your instructions carefully and it did not help. What DID make a difference was simply deleting the com.apple.sidebarlists.plist file and rebooting so that Lion created a new one. FURTHERMORE this Lion installation of mine was created cleanly from a virgin installation of Snow Leopard and NOTHING in it was copied from a previous installation. No migrated settings, no nothing. So for now, with a new blank .plist, the mysterious icon has gone away.
    – user9290
    Commented Aug 12, 2011 at 4:11
  • Curious. From 10.6.8 or an earlier version of 10.6.x? My guess was that removing something Network -related from within the favorites key (plus maybe a log out) would do the trick. Since you describe the cleanliness, there remains a puzzle. discussions.apple.com/message/8137918#8137918 (thanks to Alex for the link to that topic) suggests a major change between Tiger and Leopard, whether there's a comparable change between Snow Leopard and Lion I don't know. Has your computer even been amongst a network of managed computers? Is there a /Library/Managed Preferences/ directory? Commented Aug 12, 2011 at 5:22
  • 1
    No, and no. No /Library/Managed Preferences/ directory. It's never been on a network of managed Macs. It's been ON a LAN with a Windows Active Directory controller but it has not been joined to the Active Director network.I have an unsubstantiated suspicion that it has something to do with the fact that it's a Late 2007 MacBook Pro and several hardware particulars are not Lion-compatible. Atheros but no AirDrop, no multi-touch trackpad, unpredictable keyboard backlighting, and other quirks.
    – user9290
    Commented Aug 12, 2011 at 5:40
  • On this MacBook I do have VMware Fusion with Windows 7 Professional 32-bit, and it is managed by that Active Directory server on the LAN I mentioned on the two days a month that I take it to a certain company where I'm a consultant. When the VMware virtual machine is active and running, it shows up as another host under Lion's Finder sidebar under "Devices".
    – user9290
    Commented Aug 12, 2011 at 5:41

I know this is an old thread and I am unsure if you've solved this problem or not, but I thought I'd still post as it could potentially help others that come across this problem. I noticed recently that I, too, had this 'Network' appear on my Finder sidebar. When I clicked it, it did nothing at all and I could not remove it by right clicking. Pretty much I was in the same situation. As a solution to rid of it, I simply held [option]+[command] and dragged it on to the desktop, then poof, problem solved.



This icon is a gateway to all the networked storage devices, computers, and printers on your local network IF there are any. This can also be access from the GO menu of the finder, or using the shortcut ⌘⇧K. It might not have any function if no such devices are present. If the sidebar item is annoying you, you can simply remove it by right clicking it.

  • No, I CANNOT disable it by right-clicking on it, and I cannot drag it from the sidebar onto the desktop and make it go "poof". There are other network storage devices and computers on my LAN, but the Network icon will not display any of them. I can display these devices under "Shared" and "Devices" in the Sidebar, and when I select the Sidebar icon for my MacBook, in the pane on the right there is the coventional Network icon, under which I can see all the devices on my LAN just like I could under Snow Leopard. But on my system the Network icon in Sidebar remains non-functional.
    – user9290
    Commented Aug 8, 2011 at 18:46
  • huh that is weird :P
    – Alexander
    Commented Aug 9, 2011 at 0:03
  • Was that really worth a down vote though? i spent time trying to answer your question, it's not like i'm posting spam or something
    – Alexander
    Commented Aug 9, 2011 at 3:01
  • XAleXOwnZX, I am new here and I am still learning the proper site etiquette. Please forgive my impulsive move in voting your comment down. I am learning from my mistakes.
    – user9290
    Commented Aug 9, 2011 at 3:13
  • it's fine i'm not asking for a thumbs up it's just not necessary to vote down when i spent the time trying to help, you can undo the down vote by clicking it again :)
    – Alexander
    Commented Aug 10, 2011 at 0:10

From the root of your computer there is an item 'Network'. I assume this is a favorite to that. I've just been playing around and can't see it, but I so have various networked devices in Shared, and in Devices, so no idea what it's for. Remove it if it bothers you.

For me all the items in Network from my computer root appear on the sidebar in Shared.

When it is present does it match a time a device on your network is active or sharing something? Eg. someone using iTunes with sharing on. This might be linked to Bonjour.

To remove: From Finder: File -> Preferences -> Sidebar. From there you can remove it if it has no use.

  • No, I cannot remove it. There is no item named "Network" in File: Preferences: Sidebar. Please see the screen shot above.
    – user9290
    Commented Aug 9, 2011 at 5:37
  • 1
    Odder and odder then. Perhaps wait until it is appearing and see if it's there in the preferences? That's the place to permanently remove it. discussions.apple.com/thread/1719892?start=0&tstart=0 would imply you shouldn't have it at all.
    – Alex
    Commented Aug 9, 2011 at 5:53

For me, this shortcut was something that was brought over from Leopard/Snow Leopard days. My account has always been migrated, and I had the very same question as yours. I recently bought a new MacBook Air with Lion preinstalled, and I set this up as a new secondary account and there is no Network shortcut visible (even when I have other Macs on the same network as per your addendum).

You must log in to answer this question.