1

Please see this image:

red box in finder icon

I don't know what's going on with that icon, but it has been persistent for the past week. It became like that when I forced the shutdown on my Mac because it hanged up. I've just upgraded to El Capitan when it happened.

I've tried the following:

  • Reboot
  • Relaunch Finder
  • Quit Finder and Dock on Activity Terminal
  • killall Dock

Nothing worked so far.

Update:

As per user24601's suggestion, I've tried the following:

  • Turned on magnification. It persists on zoom. Please see image:

magnified

  • Tried to change position. It still persists:

vertical dock

  • Interesting! Did you try killall Dock in terminal? – bjbk Oct 7 '15 at 0:13
  • Several times. I also found out that killing the Dock and relaunching Finder does not relaunch Dock. I just did it now, and while the behavior changed (Dock relaunched), the icon remains the same. – IBG Oct 7 '15 at 0:44
  • 1
    You might want to update your question with the steps you took already to try to fix it but without success. Cheers! – bjbk Oct 7 '15 at 1:14
  • 1
    If you turn on Dock Magnification, does the red box grow with the icon? – user24601 Oct 8 '15 at 2:37
  • @user24601 yes, please see updated question. – IBG Oct 8 '15 at 2:55
2

I ended up reporting it as deeeeeeekun suggested. Some of the suggested workaround in the comments were also suggested to me. This is the solution they gave that worked:

1) cd getconf DARWIN_USER_CACHE_DIR

2) attach com.apple.dock.iconcache to radar

3) rm com.apple.dock.iconcache; killall Dock

I'll update the answer when they give me the reason why the redbox happened.

1

It could well be a bug. You can try sending feedback to Apple.

0

Try doing a Safe Mode startup (hold down the Shift key right after the start-up chime.)

Getting to the user Desktop may take longer than usual as there are several things OS X is doing during a Safe Mode such as checking the integrity of the boot disk and deleting cache files. Once Safe Mode finishes, restart.

-1

I had the same problem with a half red/pink box on my finder icon (like a hat).

Just a 'killall Dock' command in the Terminal fixed it.

-1

Looks a lot like an accessibility feature. Check under that section in System Preferences.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .