16

I have upgraded from Yosemite to El Capitan. This version is stable enough but when I let my macbook pro 15" (2013) sleeping at night and reopening at the morning, keyboard and trackpad do not work anymore...

This issue never happened before and I tried to reset PRAM and SMC but nothing works.

I also tried to troubleshoot it by looking at logs and I spot these 2 lines:

06/10/15 09:25:20,000 kernel[0]: USBF:    21910.354    IOUSBHIDDriver(AppleUSBTCKeyboard)::RearmInterruptRead  returning error 0xe00002d8 (device is not ready), not issuing any reads to device
06/10/15 09:25:20,000 kernel[0]: USBF:    21910.379    IOUSBHIDDriver(AppleUSBMultitouchDriver)::RearmInterruptRead  returning error 0xe00002d8 (device is not ready), not issuing any reads to device

So I found that the IOUSBHIDDriver module was not load by the kernel, so I searched how to load it manually.

I did:

kextstat | grep -i "IOUSBHID*" (which return nothing, normal the module is unloaded)
kextload -b com.apple.iokit.IOUSBHIDDriver
kextstat | grep -i "IOUSBHID*"
   65    3 0xffffff7f817f0000 0xa000     0xa000     com.apple.iokit.IOUSBHIDDriver (900.4.1) 7180DE6A-7FF9-35D5-A78A-8C417A4BD45E <39 33 5 4 3 1>

Keyboard and trackpad still not working...

I check once again that the module is still loaded and it's not.

Am I alone with this problem ? Do you have any workaround waiting for an eventual patch from Apple ? Please do not tell me to reinstall.. It's not a real solution.

Thanks

Edit: today I didn't got the problem.. Let see tomorrow morning

8
  • 1
    I can`t type password and use trackpad after restart when the filevault is on. After i turn off filevault everything is ok. Please help. Macbook air 13 mid 2013, El Capitan 10.11
    – user150875
    Oct 6, 2015 at 21:43
  • 2
    I am having the same exact issue. However, I can see all the "taps" I did in the diagnostic logs (even though the keyboard and trackpad weren't responding). They show under "MT Gesture Parser" from the message domain "com.apple.MultitouchSupport.gesturestats." I will disable multitouch support and see if that resolves the issue.
    – MEE
    Oct 7, 2015 at 16:11
  • Today my macbook pro was stuck once again with this issue, but what I notice is that the 2 last days it was ok... I am wondering if it's related to VMWare Fusion drivers. I explain: During the 2 last days I have shut down my vm before going to sleep and at the morning everything was ok until this morning because I forget to switch my vm off yesterday night.. I will check if it's related.. Are you guys using a VM (VirtualBox or VMWare ?)..
    – eVoxmusic
    Oct 9, 2015 at 9:53
  • 1
    I confirm that switching off VMWare tonight making my keyboard and trackpad working this morning. I guess that's an issue with VMWare kernel drivers... Tonight I will try to let it started to confirm that.
    – eVoxmusic
    Oct 10, 2015 at 8:42
  • 1
    I have VMWare Fusion. I will keep an eye when this happens again and will let you know if shutting down Fusion solves the issue.
    – MEE
    Oct 11, 2015 at 1:15

2 Answers 2

14

Ok I can confirm that the keyboard and trackpad are stuck after sleep when I let VMWare Fusion running... If you have something similar that's running in background it could be the problem.

To resolve it at the moment I pause all Virtual Machines and everything goes alright now.

This is probably related to kernel modules installed by VMWare but I can't find any clue...

12
  • What version of VMWare Fusion are you using? I'm am also using VMWare Fusion but I haven't upgraded to 8 yet (on 7.1.2) and am wondering if upgrading could fix. Oct 17, 2015 at 12:26
  • I was on 6.x and now on 8.0.1 and it's still the same..
    – eVoxmusic
    Oct 17, 2015 at 12:34
  • 1
    Bummer. Allegedly, VMWare knows about this and is developing a fix - discussions.apple.com/thread/7261273#29072453. Here's hoping. Oct 17, 2015 at 12:39
  • 2
    Is there some news about this? I have the newest VMWare Fusion 7, and have this problem now. Jan 22, 2016 at 9:28
  • 1
    I have this same issue with OSX 10.11.4 and Vmware Fusion 7.1.3
    – cjackson
    Jun 26, 2016 at 1:24
1

If you don't want to reinstall, why not run the installer against a clean external USB drive. Does the trackpad work there? Does the trackpad work when you boot to the Recovery HD?

Those two things will tell you if you have a hardware issue (trackpad won't work anywhere) or a software issue (trackpad either will work in a new user account and not your specific user account) or a system issue (works in Recovery HD but not in your current system.

Based on where the problem lies, the solutions depend. You don't need a hardware repair if it's software and the software repair changes depending on what isolation steps pass.

2
  • Keyboard ans trackpad works after a restart, it's not a hardware issue.. It's bug due to this upgrade. Reinstalling has never been a solution.
    – eVoxmusic
    Oct 7, 2015 at 6:56
  • But I will try to repair it by reinstalling the latest version without wiping the current one.
    – eVoxmusic
    Oct 7, 2015 at 7:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .