1

I finally upgraded from Snow Leopard to Mountain Lion (I didn't trust my older iMac (iMac11,3) to run the newest OS X) but now I can't install an important security update, the Security Update 2015-006 1.0.

I'm totally at a loss. I even booted up into the recovery mode, repaired all disk/permissions (didn't see anything serious anyway) and then re-installed Mountain Lion all over again. I'm still getting an error when I try to install it though.

It downloads just fine, and gets to the end of the install process after rebooting, but just gives an "unexpected error."

How can I fix this?

EDIT: I tried downloading and installing the standalone update, but it didn't work either. Here are (what I understand to be) the output logs from the end of the installation process, when it fails:

Oct  6 05:16:42 homebase-iMac.local com.apple.kextd[12]: kextcache error while updating / (error count: 28)
Oct  6 05:16:43 homebase-iMac.local mds[761]: (Normal) ImportServer: Software update complete
Oct  6 05:16:43 homebase-iMac.local com.apple.SecurityServer[15]: Succeeded authorizing right 'com.apple.ServiceManagement.daemons.modify' by client '/usr/libexec/UserEventAgent' [11] for authorization created by '/usr/libexec/UserEventAgent' [11] (100012,0)
Oct  6 05:16:44 homebase-iMac.local Installer[928]: CoreAnimation: warning, deleted thread with uncommitted CATransaction; set CA_DEBUG_TRANSACTIONS=1 in environment to log backtraces.
Oct  6 05:16:44 homebase-iMac.local Installer[928]: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
Oct  6 05:16:48 homebase-iMac.local com.apple.kextd[12]: /: kextcache has had enough tries; not launching any more
  • Did you install the latest Mountain Lion or the Combo updater? – klanomath Oct 6 '15 at 9:50
  • I don't know what the Combo updater is. I just purchased and downloaded Mountain Lion from the Mac website. – Patch Oct 6 '15 at 9:57
  • Please check the version of Mountain Lion in "About your Mac...". It should read 10.8.5. What kind of Mac model (e.g. iMac8,1) do you have? Did you apply all available updates before installing Security Update 2015-006 1.0? – klanomath Oct 6 '15 at 10:00
  • It is indeed 10.8.5. I have an iMac from late 2010. 27inch – Patch Oct 6 '15 at 10:02
  • I'd expect a third-party kext or a malformed plist to interrupt the update. Did you already try to boot in safe mode and install the security update? – klanomath Oct 6 '15 at 10:38
0

Thank you, klanomath for the suggestion, I wasn't aware of Safe Mode. Unfortunately, I cannot speak to whether or not this would have fixed the issue. This is because I tried this solution before you posted, and it worked.

I'm not very adept at debugging, but I was glad this method finally helped me get everything squared away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .