0

I have recently done a clean reinstall of OS X to fix my corrupted drive and everything is fine running Mavericks. However, I have been trying to upgrade to Yosemite, first by downloading from App Store and then installing from there, and then by creating a bootable usb, only to be met both times with the error,

"This copy of the Install OS X Yosemite application can’t be verified. It may have been corrupted or tampered with during downloading"

Again, I tried this with an El Capitan installer from the app store, and both methods gave the same error

Any advice is appreciated.

Note: My data and time is correct - updated automatically so this is not the issue

  • Did ya ever figure it out? – James T Snell May 26 '16 at 0:07
  • @Doc I think it ended up working after 20 attempts. I have no idea what the problem was, and I still get an error when I go to update my machine so this issue is definitely not resolved. – Steve May 26 '16 at 5:05
  • I've been having this and similar issues. I suspect my SSD's got a small hardware fault that's causing this. So far no certainty on that though. – James T Snell May 26 '16 at 18:01

You must log in to answer this question.

Browse other questions tagged .