0

Had to do a reset to factory settings of my iPhone today. I backed it up before doing this. I now want to restore to the backup done earlier today...but when I click on "restore backup" today's backup isn't one of the options. The latest one I'm given the option on is Sept 15, 2015. Help!

How can I restore the earlier backup from today when iTunes isn't giving me that option? Thanks.

1

I am assuming you have looked through the drop down menu for backups and didn't see your most current one. Have you tried restarting iTunes/MAC or PC? If restarting didn't help...

In that case I would look at the iTunes backup folder to see if the latest one was even created. Go to the iTunes mobile back up folder. Here is how to find that folder:

Under Windows Vista, Windows 7, Windows 8 or Windows 10, stored in \Users(username)\AppData\Roaming\Apple Computer\MobileSync\Backup

Under Mac OS X, stored in \Users(username)/Library/Application Support/MobileSync/Backup/.

You should see bunch of files that have random character file names. Sort them by date and see if the one you just created is there. If not, then your only option is to use the Sept. 15 backup.

If it is there... Back up all your backups to another location! (keep in mind that backups can be large and you may need extra storage space and it may take a long time to copy all the backups). There are software out there available that will make backups for you if you aren't comfortable doing this yourself. You can also take your computer and iPhone to the Apple store and they should help you with this.

What I have done in the past is copy all the backups to another folder (with iTunes closed). Then I deleted all backups in the backup folder leaving only the one I want iTunes to use. Please be careful with this step as you may risk loosing all your backups. Then restart your iTunes and the right backup should be there. If it isn't there, then the backup maybe corrupted and in that case I wouldn't even try to use it.

Don't forget to put all the other backups back into the backup folder in case you want to use them at another time.

  • Thanks for the answer and troubleshooting...I figured out what was wrong. See answer. – Sizzle Oct 5 '15 at 17:19
  • Great!. I am glad you resolved it! – user150555 Oct 5 '15 at 18:52
0

The issue, it turns out, was that I had backed up my iphone yesterday with an iOS 9.1 beta backup. I then installed iOS 9.02 - the latest public version of iOS. When I tried to restore the backup I was unable to because the operating system I was running was older than the one of the backup. A boneheaded mistake that has now been fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .