7

In the new El Capitan version of OS X, in safari 9, in fullscreen if you move your cursor to the left, it shows the sidebar.

Is there a way to disable it ?

3
  • I do not get this behavior. Does command+shift+L make the Safari sidebar go away and stay away?
    – Jeff
    Oct 5 '15 at 0:05
  • Yes it does, you need to put your cursor to the left, and wait for 2, 3 seconds in full screen.
    – Anas
    Oct 5 '15 at 0:38
  • 2
    Thanks for the dock on the left solution but honestly i think that most of us want to still be able to chose the side of the dock, and not be restrained to us FOUR FINGERS every time the dock is needed...please keep on sending the report. apple.com/feedback/safari.html
    – user157937
    Nov 18 '15 at 0:10
3

Simply copy and paste one or both into Terminal:

defaults write com.apple.safari ShowSidebarInTopSites bool=FALSE
defaults write com.apple.safari ShowSidebarInNewWindows bool=FALSE

If you don't want to copy two commands, then you can do both at the same time:

defaults write com.apple.safari ShowSidebarInTopSites bool=FALSE; defaults write com.apple.safari ShowSidebarInNewWindows bool=FALSE
4
  • 2
    This doesn't work for me.
    – Peanut
    Aug 13 '16 at 2:34
  • 1
    Thanks, but using code or any other gimmick to adjust a (not so friendly UX) feature on Safari is quite upsetting. I am all-in for Apple products and services but its amazing how they are doing nothing to remove/edit the default setting for this (annoying) tool. So many users are reporting that they hate it.. and still no one seems to care.. it just doesn't make any sense..
    – Mike
    Jul 29 '17 at 11:40
  • I tried both of these in Terminal... defaults write com.apple.safari ShowSidebarInTopSites bool=FALSE defaults write com.apple.safari ShowSidebarInNewWindows bool=FALSE The first didn't work, but the second did! Thanks!
    – Brad Trent
    Aug 22 '17 at 20:24
  • 1
    Does not seem to work in Safari 11.0.3 on macOS High Sierra (10.13.3).
    – Bart Doe
    Mar 4 '18 at 7:17
0

I have found an "solution" Just put your dock on the left side and the problem was resolved. But PLEASE send your feedback here : http://www.apple.com/feedback/safari.html

1
  • 1
    That does not actually stop it. In most cases yes but if you stop the mouse just right the sidebar will show. I have tested and repeated this a few times now
    – markhunte
    Oct 10 '15 at 8:00
0

Just keep using Safari in fullscreen with the dock set to the left side in System Preferences. Enter this command in Terminal without quotes: "defaults write com.apple.Dock autohide-delay -float 1000 && killall Dock" This will fix the issue. Note: the dock will need the "Mission Control four finger swipe up" to show/hide it. To make things back the way they were, enter this in Terminal: "defaults delete com.apple.Dock autohide-delay && killall Dock"

1
  • If anyone can write code to disable this auto sidebar, I will send them $20 with Paypal.
    – Elias C
    Aug 22 '16 at 2:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .