4

I recently purchases a Sennheiser G4ME Zero to replace my Steel Series Siberia V3. The Siberia's microphone worked just fine along with the audio. When I plugged my G4ME Zero in the audio output worked great. When I tested out the microphone, my Macbook didn't receive any input. I plugged in my old Siberia to see if it was a hardware problem with the Mac but it showed up as a working external mic.

I've tried switching out cords, blowing out the input, and just plugging in the microphone portion to the computer but it still won't work. Is it a hardware problem with the headset or what?

1

If you are using a MacBook with a single 3.5mm jack, you need to make sure you are using the TRRS cable from Sennheiser. That's the one that will have 3 narrow bands on the shaft of the jack (separating the four metallic connections stereo/left, stereo/right, microphone, and ground). Is that how your Siberia works? Single cable?

Also be sure that the "boom arm" is not raised up as that will mute the microphone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .