7

Like in the title, I've used ShadowKiller (very old but worked until 10.11) but it doesn't work in 10.11 and 10.12 as well (tried disabling SIP).

I've tried using the command line trick, toggle-osx-shadows from github and couple of others, it seems that something changed in 10.11

Does anybody have a solution?

  • The shadowhide method when taking screencapture is also not working in 10.12 Sierra. – FrontENG Nov 25 '16 at 5:11
  • Why would anyone want to do this? Just curious. – user14492 Nov 30 '16 at 23:21
  • There are couple of use cases, like tiling window managers for example - normally shadows overlap on other app's window which doesn't look good. I do it for pure aesthetic reasons as well, it looks better that way. – lavventura Dec 2 '16 at 21:02
7
+50

There is a solution - SIMBL plugin called winBuddy which is available through mySIMBL.

It allows you to turn off window shadow and/or window borders for every app.

I've just tested it and it seems to work properly, there are some minor glitches here and there but nothing major and I think they will get fixed soon.

Minor glitches include:

  • You can't change window options for apps which don't have menu - like Bartender for example
  • You can't change window options for some apps, as winBuddy does not show up under 'Window' in menu.

edit: I've forked winBuddy and created a version which has window borders set to OFF by default for all apps (that is the look I was going for), maybe someone finds it useful.

  • This is a great find. Thanks for sharing it! I see this issue pop up regularly in various forums etc and now I'll be able to offer a solution! :) – Monomeeth Nov 30 '16 at 6:36
  • No problem, happy to help :) – lavventura Dec 2 '16 at 21:00
  • This is fantastic! And also, the main fork of winBuddy now has "Hide Shadows" turned on by default... so this is a very nice solution. The only thing to remember is you have to disable System Integrity Protection to complete the SIMBL install. – Camden S. Jul 12 '17 at 15:57
  • Mojave reporting, nothing works. – jason Apr 25 at 2:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .