4

I recently upgraded to El Capitan and it broke my Macports as well as some of the compilers I use, so I'm trying to upgrade Xcode from 6 to 7.

First, I tried the ordinary way; i.e. click the "upgrade" button in the App Store. However, clicking it greyed it out for about 10 sec, and then it ungreyed as if nothing happened. It didn't show the usual "installing, 45 min remaining" progress bar that the App Store usually showed.

Then I went into /Applications folder and manually deleted the Xcode app and then emptied the trash. In Finder, I had the "details" view set up, so I could see date modified, size etc. For the size field for the Xcode icon/entry, it actually had a progress bar that was about 5% filled for some reason. I wasn't sure what this meant, but I deleted Xcode anyone. I only realized after deleting Xcode that this icon was not my previous Xcode version 6, but it was the App Store actually trying to install Xcode 7. I was confused because, as I noted above, when I clicked the update button in App Store, it didn't show the progress bar, it just momentarily greyed and ungreyed.

However, I then restarted my computer, and now when I go to App Store, the Xcode update doesn't appear in my Updates "panel" at all. I searched for Xcode in the App Store, and there's a button that says "install". I click it and nothing happens. I also tried searching for Xcode on google, and the page simply tells me to go to App Store. I guess my other options are to install the Xcode 7.1 beta, or re-install a previous version, say Xcode 6 from an installation file, but I would prefer to install the current stable version (although from App Store reviews it seems like the current Xcode is none too popular).

Anyone know how I can do this now? It seems like the app store process for installing Xcode 7 is majorly majorly screwed up, at least for my particular machine.

  • 1
    I've also seen App Store get confused, or maybe not provide enough feedback so I get confused. I don't know how to fix that, but to download Xcode, try developer.apple.com/downloads. – blm Oct 4 '15 at 16:25
  • Welcome to AskDifferent! Glad you were able to figure out what was going on there. Something you may want to try is to move your edit into its own answer to the question, as that would be a great thing to point anyone else at that runs into this problem. – Mikey T.K. Oct 4 '15 at 20:35
  • Ok, I just moved the edit to an answer! – xdavidliu Oct 5 '15 at 15:21
4

Okay, solved: I just clicked the "Purchased" tab in my App Store, and it looks like it was installing the entire time.

This was extremely confusing, because for some reason there was absolutely no indication in the Updates tab that Xcode was installing or downloading (as there usually is for updates), so I didn't even realize that it was installing. There was also no indication in the "App Search" Panel where I got the page for Xcode with the install button on it, i.e. when I clicked the button, the only thing that happened was the button changed to "installing", and there was no progress bars or statuses anywhere in sight, so I wasn't sure if it was actually installing or just hanging.

I just realized, since I DELETED the entire Xcode the very first time, when I'm installing Xcode it doesn't count as an Update, so that's why it does not appear in the Updates tab. I guess when I searched for Xcode in the App store, and clicked Install, it was installing in the Purchased tab.

  • It is very confusing that the progress bar does not show up in Updates, and the update button becomes ungraded out. Thanks for the lead. I was half way downloading the dmg from the apple developer site and saw your post. Sure enough Purchased had about 10% left. – tofutim Nov 14 '15 at 0:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .