I've deleted my recovery disk; or you can say more accurately, I've completely erased, by mistake, my SSD.

Now, my only option is to recover via Internet, but the globe on Internet recovery keeps on spinning and stuck at estimated time at 2:53. The Internet is working fine, all other websites and download working fine, but the globe is stuck.

Please help, what should I do? I can't log in, I just see a blinking folder and Command R takes me directly to Internet recovery!

Model is Macbook Pro Mid 2014

  • Do you have another Mac available? Commented Oct 4, 2015 at 16:18
  • No Sir. I don't have another Mac. Commented Oct 4, 2015 at 16:21
  • I am in the same situation. Not sure if my narrative will help. I attempted two OS upgrades, both failed. First, I downloaded the new OS with the iTunes Store. After the long download and during the install the system just kept restarting. Second attempt, i used the recovery mode to check disks and to attempt reinstall the OS. i had the same results as the first. So, I deleted the HD and attempted to install fresh OS; however, the Internet recover will no longer load. I am stuck at a gray page with a spinning globe. Any advice is greatly appreciated!
    – user150430
    Commented Oct 5, 2015 at 2:36
  • Well, I tried thrice for internet recovery. Even after 12 hours the globe stops spinning and had to start over and still no luck! This time globe doesn't show any ETA. Commented Oct 5, 2015 at 3:52

7 Answers 7


Without a recovery partition and (for whatever reason) your Internet Recovery just won't work, you are down to about 3 options to get OS X installed:

Option 1: Install (or Recovery) at an Apple Store

If you are close to an Apple Store you can go into one and download the latest OS (if you have a working Mac) or run Internet Recovery using the Apple Network.

Note: Internet Recovery will only install the last version you had, it won't upgrade. For example, if you had Mavericks before and want to go to El Capitan, you will have to recover to Mavericks then download the El Capitan Installer.

Option 2: Download and Make a USB Installer

This involves using another Mac from a friend, family member or acquaintance. You will need an 8GB flash drive. There are many guides on how to create the USB installer so I won't belabor that point here, but the command you will need to execute in Terminal is as follows:

sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/<USB Volume> --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction

Where <USB Volume> is the name of your USB Flash Drive (don't use spaces - it makes it easier)

After about 10 minutes you will have a USB Flash drive to install OS X on your Mac.

Option 3: Acquire a premade USB Drive

This is not an official recommendation but sometimes when you are in a pinch and Options 1 and 2 are simply not feasible, it's nice to know that there's another option. You can find these on eBay. I have used this option before when I had to restore a Macbook, Internet speed was slightly above dial up and the closest Apple store was in the next State.

Just make sure you you deal with a reputable US based seller with good feedback. If the seller is too new or feedback to low, look elsewhere even if the price is good.


Are you behind a firewall, which stops any connections outgoing to / incoming from Apple Servers? Are you using the Mac at work? If yes, that is likely the cause of your issue - Either the connection is very slow due to Authentication on the firewall, or Apple Servers are blocked by the Firewall. Try a different connection (different WiFi) or connection type (Wireless or Wired).

Happened to me once, couldn't download updates for an iPhone, and a very slow Internet Recovery on a Mac due to a Firewall authenticating with Apple Servers. I connected with another internet connection without the mentioned authentication, and the Internet Recovery was faster.

  • This worked for me on my home network. I turned off router firewall, and presto, internet recovery worked like a charm.
    – Mr. J
    Commented Nov 13, 2020 at 23:51

Same issue was true of me until I had changed my DNS addresses from router. Some countries are hindered to access Apple servers or vice-versa. However, it easily is fixed by changing DNS addresses, watch out, on router. When I was doing it, I used Google DNSes /

  • 2
    Changing DNS to Google's public DNS / worked for me
    – Roy
    Commented Aug 20, 2018 at 20:56

I would write OS X on a USB stick and boot from it.

You will need:

  • A working PC, which I'm assuming runs some version of Windows.
  • A USB stick.

Follow these steps:

  1. First, get a .dmg of the OS X's version you need.
  2. Download the 15-days trial version of TransMac.
  3. Backup any data from the USB stick. You are going to erase it entirely.
  4. Launch TransMac, locate the stick, right-click on it and choose "Restore with Disk Image".
  5. Locate the .dmg image you downloaded and select it as the source.
  6. Once finished, push the stick in your Mac.
  7. Power it and keep pressing the alt key until some icon pops up.
  8. If you really erased the entire disk, there should be just one, and should be named something like "OS X Install".

I had the same symptoms (globe and timer stuck, even overnight), but the issue was different. I just disconnected my external USB C display and Internet Recovery started in a couple of minutes.


You simply need an external bootable .dmg file connected to the hardware via USB, SD card or external HDD. The OS on the bootable media can be macOS Sierra or any other version of macOS as long as it is supported by your system. The bootable media can be created using another Mac using the OS downloaded directly from the App Store.


I had the same issue. I went and tried on a different on internet connection and it worked. So I guess you try a really really fast internet connection. It will work, don't give up.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .