I run my own CalDAV/CardDAV-server to synchronize all my calendar events and contacts across my devices. Everything was working fine until I upgraded to El Capitan a few days ago.

Now Addressbook can't connect to the CardDAV-server anymore. After I checked the logfiles on my server, I figured out what the problem is: The setup assistant in System Preferences asks for the server address but actually saves a completely different (maybe standard) address, which then of course won't work.

Does someone know how to fix this? Maybe I can change the values via Terminal and change the settings there.

It also seems that these accounts don't sync properly via iCloud, which makes the account working fine on one machine and not working on the other machine. Of course I can't delete the synced account there and make a new one because then it will just move the problem between the machines.


2 Answers 2


Something is clearly broken with El Capitan and CardDAV, but I could make it work by:

  1. properly set up the standard /.well-known/carddav and /.well-known/caldav redirects (see your CardDAV server documentation to see the destination URL)

  2. use the Manuel settings type - there are now 3 types of CardDAV configurations in El Capitan: Automatic, Manual and Advanced. In my experience Advanced is really broken in 11.11.0, but Manual can work with a server configured as described in #1

  • Thanks, this actually helped me get the account set up without error messages. (Btw: this here might help others set the redirects up: link) I was also able to download all the contacts from the server. But I still have issues with it, like when I delete a contact, it disappears from my local machine but still exists on the server.
    – comfreak
    Oct 16, 2015 at 12:00
  • Especially point #2 was helping me with my Synology CardDAV. Advanced connect does not work, but connecting with hostname:port is accepted and works now. Thank you!
    – Sevyls
    Nov 15, 2015 at 16:31
  • Soo, I had this problem in 2021 with Big Sur, and sure enough, changing the account type from 'Advanced' to 'Manual' fixed the problem. With the same settings nonetheless.
    – Toby
    Mar 15, 2021 at 19:45

I don't know how iCloud but we problem with carddav too. I can't add CardDav account it says: Unable to verify account or password. Logs here:

 05/10/15 10:04:49,308  accountsd[920]  [CardDAVPlugin] +testConnectionFuture input:{
    acAccountIdentifier = "77105671-722A-4920-B0E5-87DB9D98BBA2";
    acAccountTypeIdentifier = "com.apple.account.CardDAV";
    path = "";
    scheme = https;
    serverName = "server.something";
05/10/15 10:04:49,309   accountsd[920]  [CardDAVPlugin] TestConnection: Addl Acct Info [Before]: {
05/10/15 10:04:49,316   accountsd[920]  [CardDAVPlugin] TestConnection: Addl Acct Info [After]: {
05/10/15 10:04:49,316   accountsd[920]  [CardDAVPlugin-ERROR] No 'AddlInfoKey' present to save: {
05/10/15 10:04:50,875   accountsd[3673] [CardDAVPlugin-ERROR] No 'AddlInfoKey' present to save: {
05/10/15 10:05:01,681   accountsd[3684] [CardDAVPlugin-ERROR] No 'AddlInfoKey' present to save: {

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .