15

I know it should be straight forward but unfortunately, it isn't.

I did disable the guest user in the System Preferences by unchecking the checkbox for Allow guests to login in to this computer, but it still shows up on the login screen.

I have heard that disabling 'Find My Mac' would fix it for OS X Lion, but I want to keep it.

Is there a way to do this?

  • 1
    Same Here. I have 2 recently wiped to Yosemite, cleanly updated to El Capitan, and one of the machines had no issues with removing the guest account, and the other it just won't go away. I am going to turn off find my mac on the offending one, see if I can remove the guest account, and then turn find my mac back on. I'll repost the results. – user150350 Oct 4 '15 at 18:45
  • I have the same problem plus I'm experiencing some trouble with the cursor. The cursor is really slow before I login and soft clicks don't work. It's like my settings are only functioning once I'm logged in, which is pretty upsetting me. Can anyone help? – user150496 Oct 5 '15 at 10:10
  • Out of curiosity, what happens when you click on the guest icon on the login screen - does it let you in anyways? – Mikey T.K. Oct 8 '15 at 2:55
  • @MikeyT.K. It asks me to restart that will get me into Safari-only mode. – Rahul Desai Oct 9 '15 at 0:12
  • 7
    The point is to make Find My Mac work. If you turn Find My Mac off, the guest account will go away. The reason it's there if Find My Mac is on is that if someone steals your mac, it cannot report its position unless the thief connects it to a wifi network. – Alan Shutko Oct 12 '15 at 3:52

10 Answers 10

11

@alan-shutko pointed out very important info about this in his comment:

The point is to make Find My Mac work. If you turn Find My Mac off, the guest account will go away. The reason it's there if Find My Mac is on is that if someone steals your mac, it cannot report its position unless the thief connects it to a wifi network.

Looks like we should keep it on.

3

Ok there is something really broken in the User options in OS X. You can disable the guest account even though FileVault and Find My Mac are on. These are the steps that worked for me:

Step 1. Turn off the Guest User (pay attention, buggy dialog!)

  1. Go to System Preferences - Users & Groups
  2. Unlock all options using the lock on the bottom left
  3. Click on the Guest User and make sure all options are off
  4. If all options were off, enable Allow guests to log in to this computer
  5. Then click on your primary username, then go back to the Guest User and turn off all options again. The Users & Groups dialog is really buggy. It might even automatically check Enable parental controls for no reason.
  6. Before you close the dialog, make sure that all checkboxes are unchecked and that the description of the Guest User says Off.

Step 2. Turn off all Sharing options/services (for now)

  1. Go to System Preferences - Sharing
  2. Uncheck all sharing options/services

Step 3. Disable iCloud Find My Mac (for now)

  1. Go to System Preferences - iCloud
  2. Scroll down the list, and uncheck Find My Mac

Step 4. Manually delete the Guest account

  1. Open up a terminal, and execute the following command:
    sudo dscl . delete /Users/Guest

  2. Check that there is no user Guest anymore with:
    dscl . list /Users

Step 5. Reboot

  1. Make sure that all dialogs are closed
  2. Reboot

If you are lucky, your guest account is gone!
If not, retry step 4 (the dscl command) and reboot again.

Once your guest account is gone, you can re-enable iCloud Find My Mac and your sharing options/services. But stay away from the Users & Groups dialog.

2

I had the same problem myself and I couldn't find any sources on how to do it. I just found out how to do it without disabling the Find my Mac option. Here's what you have to do. Make sure you disable the Find my mac option. Then click the Apple logo on the top left side then System Preferences > Security & Privacy > General > Advanced > Check "Require an administrator password to access system-wide preferences and after than shut down then open it again. you should see you own account only there without the Guest option. Go to the system preferences again to enable find my mac.

  • 2
    It's fairly pointless having Find My Mac on if a thief cannot login to the computer at all; that's the whole point of the guest account, to entice them into getting in the 'easy way' thus enabling the find routine. – Tetsujin Nov 1 '15 at 9:59
1

I struggled with this same problem in OS X El Capitan until I discovered a rather simple solution without disabling Find My Mac or FileVault:

1) Click the Apple logo on the top left side then click,

System Preferences > Users and Groups > Login Options >

2) You'll find the selection Display login window as: , where the List of users is selected by default.

3) Select Name and password.

4) Restart. :)

The Guest account should no longer be there. If the is only one user account, you will just need to enter your password. Otherwise, with multiple user accounts you will also need to specify the Account Name.

Hope this helps. :D

  • 1
    Sadly, this didnt work for me. I followed the exact steps that you mentioned. – Rahul Desai Dec 5 '15 at 4:46
  • 1
    This won't work if FileVault is enabled – The New Guy Feb 14 '16 at 17:05
0

I kept seeing the Guest account listed on the login page. I remembered that I enabled FileVault before I had disabled the Guest account. So after I disabled the Guest account, I disabled and re-enabled FileVault. No more Guest on the login screen. But I can't completely disable the account.

0

The only way I was able to get the issue fixed on my machine was to disable the guest account and also disabled Filevault. Reboot the machine and wait for the decryption to complete. Reboot again and the issue should be resolved.

  • That seems like a terrible idea. Disabling FileVault makes it trivial to access all of your files, including any user other than guest the attacker wants. – Alan Shutko Oct 12 '15 at 0:20
  • I absolutely agree. I suspect that Apple has deliberately enabled the Guest account when FileVault is enabled. I have read threads where some users have wiped their devices completely and still faced the same issue... – Riz Oct 12 '15 at 0:23
  • 2
    Yes, Guest is deliberately enabled when FileVault and Find My Mac are on, since the only way to see where your stolen Mac ends up is if the thief can log in. – Alan Shutko Oct 12 '15 at 0:29
0

Its best to check and see if FileVault which is located in System Preferences under Security and Privacy is turned off.

That should make the Guest Account go away....

This is there so that you can have access to iCloud and you can reset your password if you forget it...

0

I found a way. I tried so many things but I don't know why it fixed my problem.

I disabled the guest account and I tried all above as well as other posts in the internet. all didn't work for me. My last try was that I created a new account in the MacBook Air. Now it shows my account and the new account only. The guest account finally is gone.

OS X got a bug worse than Windows.

0

Same problem after turned on the service “Find my Mac"...

The proposed solution did not work for me (unchecking “Find My Mac”, “Allow Guests to log in to this computer”, “Allow Guests to connect to shared folder" then rebooting my Mac).

What did work was logging out my account iCloud (system preferences > iCloud > sign out). After the reboot, the guest user has disappeared ! ;)

Last step: sign in with your iCloud account (system preferences > iCloud), reboot the system and check if the solution works for you.

OS X El Capitan v 10.11.6

-2

I did everything mentioned above and in the end, i created a new user, restarted the computer, then deleted the new user and the guest no longer shows at startup. :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .